Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1 (Edited)
Horn is not working on my 91 Vitara JLX,
fuse is good, i pulled the horn out & manually connected it to
a 12v supply & got sound. Not sure what it could be...
When i pull the wire terminals off the horn, the wire end of the terminals
are filled with some type of grease.

Any help\advice is appreaciated...

cheers.
 

·
Registered
Joined
·
2,528 Posts
The grease is most likely dielectric grease to reduce corrosion.

Sounds like your horn is fine but you have a problem with the power feed and control relay. The horn "system" runs of the same fuse as the brake lights. (Do they work?) Grounding the control lead from the relay (what happens at the horn button) would let you know if it was the button and if the relay "clicks" you have power and if the horn honks, look at the button on the steering wheel. if the relay clicks but the horn doesn't honk.... wiring to the horn or the grounding of it.

Confessed yet? ;)
 

·
Super Moderator
Joined
·
24,449 Posts
The horn circuit is fairly simple. You press the horn switch in on the steering wheel, and this provides the ground to the horn relay, via the blue/green wire. The switch in the horn relay then closes, providing the voltage to the horn itself along the green/black wire. Check your wiring as well as the ground for the horn itself (near the windshield wiper reservoir). The ground for the horn switch is in the steering column.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #4
FIXED !
I took off the steering column shroud & found that the earth wire had been broken off.
So i soldered it back on. Good as new.....
 
1 - 4 of 4 Posts
Top