Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
so lately my sidekick will start right up then once it's warmed up and goes to hot idle It will die at idle and bog out if the headlights are on when I turn them off. it starts to misfire more and more the longer it runs. I got a new tps and calibrated it correctly checked the egr(it's fine) changed the 02 sensor and changed the plugs. the cat was clogged so I cut it out(running on strait manifold) could it just be a back pressure thing? the plugs looked like it was running lean. I think iac is good. it just seems like the air fuel ratio is a little off. any other ideas what it could be? thanks
 

·
Super Moderator
Joined
·
24,471 Posts
The idle speed solenoid is a solenoid on the passenger side of the throttle body that deals with maintaining idle when you put a load on the engine. On the 89/90 it is only electrical and can only be tested when removed from the car. If you remove it, there is a small plunger inside that vibrates, which may get stuck and can be very carefully cleaned with carb cleaner to try to unstick it so that it vibrates. However, if you remove it and shake the solenoid, and it rattles then it's dead and needs to be replaced.
You should also confirm that your engine is timed correctly (compression test will prove that) and tuned up properly with spark plugs gapped at .028". Also confirm if your check engine light is on with the key on, and off once the car starts. It is normally better to diagnose with testing, etc. rather than just replacing parts in the hopes that you hit on the right one....;)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3 (Edited)
thank you il check that. and I actually did check before I replaced anything the tps it used to be much worse and it would die every time it was in gear. and the 02 sensor was bad as well. and the egr had a bad leak that I patched.
 
1 - 3 of 3 Posts
Top