Suzuki Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hello all, i recently got a 1988 samurai. Ever since I got it, it has been running very rich (literally makes my eyes water/hurt when I drive it), has a high idle, and only goes up to about 50-55 mph top speed. I took it off roading yesterday with some friends, and about 10 times I would be moving along the trail in first gear or so, everything running fine, then suddenly it would lose all power and die, with no response when hitting the throttle. After it died, it would take a while to start back up. However it did/does fine driving normally down the road. It did seem like the charcoal canister filled up with fuel and started "overflowing" out the bottom of the canister.

I tried searching online for solutions, and a stuck choke seems like it makes the most sense, however today I went outside and took the intake off, and saw that the choke valve does open when the engine warms up, so I guess that's not the problem? My "hot idle" adjustment screw is screwed out pretty much all the way...if i unscrew it anymore, the screw will just fall out. the fast idle actuator also does not come in contact with the screw that it should come in contact with, not sure why that is? But it does suck back in when i give it throttle, and then extend out when the throttle is let off.

I have checked all vacuum lines, and everything is correct. I also replaced most of them with new vac hose. I also am not 100% sure what RPMs im idling at, because i'm not sure if the aftermarket tach is reading correctly. It reads 1200 or so at idle, and the engine sounds like that is correct, but the tach seems to read low when im actually driving it. so not sure whats going on there.

Any help is appreciated! Want it to be running as best as it can for our next off road trip. Thanks!
 

·
Registered
Joined
·
25 Posts
From my experience, the only thing that can fill the canister is a stuck float. Take the top off the carb and make sure it's seated correctly and clean


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
distributor and coil were all good. I think I found the problem though...took the air horn off and that gasket was really old and falling apart, clogging some holes. Also found the float was set too high. I ordered a whole carb rebuild kit and reset the float within spec. Hopefully that fixes it, at least until I can get an engine swap done!

samuraijack, I just wanted to try and get as much info as possible lol
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
Well after taking it off road that day, and driving it all day with no problems except the dying on the trails, it decided not to start the next day, at all. long story short I took the air horn off and found a diminishing gasket. so i ordererd a carb rebuild kit and just rebuilt it last night, but its still not running. I followed the FSM step by step. it still seems like its getting way too much fuel in the bowl. its still overflowing into the charcoal canister and out the bottom. The funny thing is, with the fuel line feed (from tank) connected to the fuel pump, it wont start at all. But if i take off the fuel pump feed, it will start, but I have to give it full throttle and it will slowly start chugging, then I can stop turning the starter, pump the gas until it finally comes up to a good idle, and it will actually run nicely. But then 20 seconds later or so it dies out. If I try reconnecting the fuel line to the fuel pump while it is running, it dies about instantly.

not sure whats going on, does anyone have any idea??? I am about to just pull this engine and do a swap, but would like to get this engine back running again first...
 
1 - 10 of 10 Posts
Top