Suzuki Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok, so I just got an 86 samurai tin top. I don't know much about carbureted vehicles so this is a struggle for me.

Here is what is happening with my rig. When I got it, the carburetor was all messed up sticking and missing springs, so I bought 2 used carbs and made 1 good one. I installed it and now when I start it, it turns over, fires up and then dies. Sometime I can start it and it will idle up and down real sperattic but then it dies after 10 secs.

I've noticed that its not getting fuel into the carb. I've changed the fuel pump, filter, egr, plugs, wires, distributor, rotor, PVC valve and a few other parts. I've cleaned it and tried swapping the wiring harness to the carb and it still does the same thing. All vacuum lines are hooked up to specs.

Does anyone has any ideas or help?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Not quite the answer i was looking for lol, If I put a new carb in it ill just put a weber on it, but I have to pass smog so I need this one working.
 

·
Registered
Joined
·
11 Posts
What year models of Toyota and Corolla do I need to use on a 88. Does anyone have a picture of what of the smog control to get rid of. I want to remove it all.
 

·
Registered
Joined
·
5 Posts
try this carb

Trail Tough in Medford, Oregon has them rebuilt for $329.00 with a $100.00 core charge. Try this link for them:

Remanufactured Carb

Hope this helps.
I am having problems with the carb on both of my Sammy's. My tin top is the worst of the two. I also have to be smog legal in my county where I live.
 
1 - 9 of 9 Posts
Top