Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone,
My 2010 Kizashi has been having some transmission issues lately, for about two weeks it has been jumping around in rpm's while accelerating and in some cases it wouldn't allow me to go over speeds of 15 - 25 mph as the transmission wouldn't adjust like normal. Yesterday a transmission light appeared as I drove home with the worst that the issues have been thus far. I have called a bunch of transmission shops and most won't service it, but I did find two shops that are booked out a week that will look at it to hopefully figure out what is wrong with it.
I am posting to see if anyone has had this issue, and what can you recommend I do instead of waiting around for a week to have it looked at?
Drop the trans pan and check/change the filter(s) and add new fluid?
I just want to be productive while waiting around for about a week.
 

·
Registered
Joined
·
4,447 Posts
leave it to the pro's to look at. CVT's are very touchy and even wrong oil levels can make them do funny things. Theres a reason why most trans shops won't touch them.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Update on cvt transmission

So I had a local transmission shop look at my 2010 Kizashi, and they reported that the code that showed was a stepper motor code. They didn't do much else other than say that a new transmission was 7000 dollars from a dealer here in WA that still deals Suzuki for another year, and that they aren't able to get parts so the only option was to get a new transmission.
Is it possible to get parts for a CVT, or am I better off trying to find a used CVT to replace? Any suggestions as to what to do next?
 
1 - 3 of 3 Posts
Top