Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys,

I have that car which i mentioned in heading. I am getting CEL when it rains and when i go to car wash. After an hour it goes off. A few days ago it snowed and my car's hood was all snow. After that, check engine light came on for two days and then went off. Right now i still got it.

Everything is fine. Idling is good. Performance and fuel efficiency are good like CEL off. I wouldn't tell any difference between CEL is on and off.

Just i hate that when i start the engine it revs above 2000 rpm. And i cant use my cruise control.

Any thoughts???
 

·
Registered
Joined
·
1 Posts
Hi guys,

I have that car which i mentioned in heading. I am getting CEL when it rains and when i go to car wash. After an hour it goes off. A few days ago it snowed and my car's hood was all snow. After that, check engine light came on for two days and then went off. Right now i still got it.

Everything is fine. Idling is good. Performance and fuel efficiency are good like CEL off. I wouldn't tell any difference between CEL is on and off.

Just i hate that when i start the engine it revs above 2000 rpm. And i cant use my cruise control.

Any thoughts???
Water is probably getting some connector. Don't chase the cruise control issue. Whenever the CEL is on the cruise is disabled. If the CEL light is off, the cruise will work. Go to Auto Zone and get the code read. Look for water intrusion near the coded component. O2 sensor, Mass air flow etc.
 
1 - 3 of 3 Posts
Top