Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi,
Has anyone had their SX4 sedan a/c compressor recently replaced? My wife's a/c won't work & mechanic only had time to try adding freon which i thought was the problem. I will get a quote on Monday, but what has me wondering is that he says he needs to modify a hose or fitting, maybe to fit after market compressor? Any thoughts?
Thanks
 

·
Registered
Joined
·
849 Posts
Loss of A/C R134 is not necessarily caused by compressor failure...and you did not say if R134 was actually added and if it caused some or no effect....be more specific.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Loss of A/C R134 is not necessarily caused by compressor failure...and you did not say if R134 was actually added and if it caused some or no effect....be more specific.

Hi,
I was only told that adding freon did not fix the problem & needed a new compressor, having to modify a hose or fitting with a new compressor just didn't sound normal.
 

·
Registered
Joined
·
3 Posts
New A/C compressor for 2009 SX4 Crossover

After 9 years/82K miles of loyal service in our very HOT and HUMID climate in Florida, my SX4's A/C compressor gave up the ghost. Fortunately the mechanic who services all of my cars was able to locate a replacement compressor via the Internet (it took a while for him to find the right part and for it to arrive), but it was not cheap, nor were the labor fees to remove the bad one and replace the new one. However, it is now blowing COLD instead of tepid air, and I hope this one lasts for another 9 years. You just cannot drive a car in Florida in the summer without A/C!
 
1 - 4 of 4 Posts
Top