Suzuki Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello. I have a 2008 SX4 Hatchback, AWD with a manual transmission and around 135,000 miles. The can ran fine with absolutely no problems until this past Thursday. Took it to the grocery store without issue. Came out of the store and tried to start, but the car did not turn over. Turned the ignition off, made sure it was in neutral, pushed the clutch pedal a few times to make sure it wasn't s sticking switch - no dice. Tried jumping the car, thinking my battery had died, no luck. Had to have the car towed home. Checked the battery the next day - was reading 12.3 Volts, so I charged it up. Still no luck. I then checked all of the starting circuit fuses - they were good. Checked the relay, it tested OK, but just to be sure, swapped out with a couple others - still no dice. I then figured it was the starter. Removed and had it tested and it failed. Replaced the starter and still the car will not crank. I checked the voltage at the starter and it is good. I did find that the ground strap that is connected to the front of the engine between the radiator support and the exhaust manifold shield was basically disintegrated, so I replaced it. I verified continuity between the negative battery terminal, the new ground strap, the engine and the starter motor. It was suggested that the clutch switch may have failed. I haven't removed and checked this yet as it is up under the dash, but will do that tomorrow. Does anyone know if there is a neutral switch on the shift lever in these cars that I should be checking, too? Any other ideas that I should be looking at? Like I said, this car ran fine one minute and the next would not crank.

Any advice is greatly appreciated!
 
1 - 2 of 2 Posts
Top