Suzuki Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
I have a 2008 Suzuki Forenza with roughly 70-90k miles on it and the check engine light is on; so I took it to AutoZone to get the codes read. The codes came back saying the O2 Sensor may be bad and the code is: P2A01. The tech told me it would be in the front near the passenger side, but not where exactly; he did mentioned it would be on the bottom of the car. Where would this sensor be?

The next error is dealing with the Throttle Body; the error says the Throttle Body is damaged or bent. When my wife drives the car she says driving it on flat ground, the car will OVER rev and one time at a stop light it would not accelerate. Do I just need to clean the Throttle Body out? Where is it located? Do I just follow the air filter back to the manifold? The error code is P2106.

The last error code is dealing with the Accelerator Pedal Position. (P2138) It states that APP Sensor 1 and APP Sensor 2 disagree more than 4.5% for less than 1 second.

How do I fix these issues and how can I make the check engine light go away?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
I found the throttle body, cleaned it and replaced the air filter while I was at it. I know it needed it.

I did notice that when the car's electronics is on, the car has a long beep. While I was cleaning the throttle body, I noticed that when I pressed on it the beeping stopped. It's almost like the throttle body is jammed. It would not turn off every time I pressed on it a little bit though.

When the car is all put together and the electronics is turned on, it's like you can hear the throttle body struggling to open. (without pressing the gas)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The full P2106 error reads:

Definition:
Throttle actuator control system forced limited power

Explanation:
Bent or damaged throttle plate/body

Probable cause:
Check throttle valve control module
 

·
Registered
Joined
·
3,098 Posts
hi welcome to the forum! ok so i think all your problems are related. i think in the 08 you have the drive by wire throttle body. this means there is no cable directly linking the gas pedal and throttle body. instead its an electrical connection. so your pressing the gas and the throttle isnt opening the amount it should. the reason may be a bent throttle plate or may be something else in the system. its unusual for a throttle plate to just bend as nothing except air is supposed to come into contact with it. of course there is always the possibility that is is bent. so whats happening is that the car noticed that there was a difference in throttle depression and throttle plate angle so it put the car into a "safe" mode. this is why the car was driving strangely for your wife. simply put safe mode limits the output power of the car. now because there is a difference from the pedal to the throttle body its probably also throwing off the air fuel ratio which would give you the O2 sensor code.
so, did you have the code cleared at autozone? did the code come back again? throttle bodies are very finicky. if the space between the throttle plate and the wall of the throttle body is off even just the smallest bit it can cause a problem. messing around with it will probably just make it worse. you need to find out exactly whats wrong with the throttle body before you can decide what to do about it. the best thing to do is have it looked at by a pro. theres a possibility you might need a new throttle body or maybe just a new throttle plate. let us know what you find out. any other questions just ask!
 
1 - 6 of 6 Posts
Top