Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just bought a 2007 Suzuki SX4 (130,000 miles) on Saturday. I had a mechanic check it over before purchase. I thought the dealer said there was a new exhaust system. The mechanic recommended 2 new front tires, the tailpipe bracket be replaced, and a new battery, which the dealer has apparently done (put on 4 new tires). Saturday night, I discovered a headlight out (and opened bulb packs in the glove compartment, not there on the test drive). Sunday night, the tire pressure warning light came on (just had a flat with my mom's car). I called the salesman and brought it to the dealer Monday (said he would look at it even though sold as-is). Service ended up looking at the light and said the wrong bulb was in and replaced it and put air in tires. Monday night the check engine light came on. Auto Zone gave me the code 420. It is snowing today and I tried to put on the 4WD Hold (which I thought worked in the test drive) but that does not seem to be going into position. My last car was totaled in a parking lot and fund-wise my purchase options were limited. I see all the posts about 420 and I am getting a little worried here. Purchasing as-is makes me stuck right?
 

·
Registered
Joined
·
849 Posts
...I tried to put on the 4WD Hold (which I thought worked in the test drive) but that does not seem to be going into position. ...
You have to hold the switch down for a few seconds for 4LOCK to engage. The switch returns to rest position. 4LOCK disengages above 40mph.
 
1 - 3 of 3 Posts
Top