Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
We have a 2005 Forenza.....and recently we had a cold snap here in Arizona...it got down to 12 degrees.....thats when the problems started. I was driving to work and the headlights went out, the daytime running lights were on. That was a week or so ago.....in that week the same problem occurs.....sometimes the headlights come on.....sometimes they don't....I tried switching fuses and the lights came on. Later that night only the daytime lights came on. The brights only come on when you pull the lever all the way back. Tonight the lights completely didn't work on my wife...except the brights....no Daylights....no headlights....only brights when pulling the lever back....all the other lights work.....a coworker switched relays with the power windows....the daytime lights came back on.....but no headlights...and the power windows still worked......anyone have any ideas?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #2
Iforgot to add that my wife has already had work done on the wires behind the instrument cluster .... this was done before we were married but as we don't have a Suzuki dealership around here it was done by a shop here in town.
 

·
Registered
Joined
·
3,098 Posts
therre has been another recall on the wires behind the gauge cluster. i have an 05 reno and i got the letter maybe three months ago. so i would check the wires again
 

·
Registered
Joined
·
12 Posts
We have a 2005 Forenza.....and recently we had a cold snap here in Arizona...it got down to 12 degrees.....thats when the problems started. I was driving to work and the headlights went out, the daytime running lights were on. That was a week or so ago.....in that week the same problem occurs.....sometimes the headlights come on.....sometimes they don't....I tried switching fuses and the lights came on. Later that night only the daytime lights came on. The brights only come on when you pull the lever all the way back. Tonight the lights completely didn't work on my wife...except the brights....no Daylights....no headlights....only brights when pulling the lever back....all the other lights work.....a coworker switched relays with the power windows....the daytime lights came back on.....but no headlights...and the power windows still worked......anyone have any ideas?
just got mine fixed....recalls warrented repair due to recallllllllllllll.. no cost to you.....
 
1 - 4 of 4 Posts
Top