Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,

Sorry to bother ...

I have a 2001 Esteem Wagon with a "weird" problem.

It runs great for days with no problem. But randomly, it will "stutter" almost turning off.
If I hit the gas it seems to want to choke running even slower like crawling and very hesitant.

I discovered that when the "stutter" begins, if I put it in neutral while in motion, turn it off\on the problem
goes away instantly regainging all its power. I put it back in drive while still in motion and the problem is gone for minutes, hours or days.

Something "clears" the problem when I instantly turn the car off and back on within seconds. It will run great
at fast speeds again as if nothing had happened. This problem may come back within minutes or will disappear for days or even weeks.

The CLUE is that everytime I turn my car off/on it will instantly recover to normal drive.
This tends to happen more when the AC is running. Without the AC on it will not happen as often.

I am not a mechanic and the few mechanics that have looked at it cant find the problem.

Any ideas?

Thanks
 

·
Registered
Joined
·
8,499 Posts
I presume those mechanics are code readers!

Try cleaning the throttle body, get all the crud off the butterfly and bore... Then check the EGR valve
 

·
Registered
Joined
·
110 Posts
Right on aquanaut20! Also, does the tachometer drop while you're driving then jump back to a regular reading? Does it stall?
 
1 - 3 of 3 Posts
Top