Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello!
As said above our GV wont start, it's not the battery. I've been doing some reading and my husband is picking up a new fuel pump, and spark plugs just in case, but I also read about the AIC valve being an issue. The reason I'm posting is because something funny has been happening with it for a number of months that I'm wondering if it's related.

The issue is that whenever we park "suddenly", as in come to a rapid stop and "throw" the vehicle into park it dies. If we come to a gentle stop, or let it idle for a bit before putting it into park it is usually fine. Putting it into park seems to be the "trigger" for it dying. It's always started up just fine afterwards, and it never had a problem with idling so I don't think it's a fuel filter issue.

Anyways if you have any ideas on what else could be going on your help is much appreciated. Thanks!
 

·
Registered
Joined
·
2,528 Posts

·
Super Moderator
Joined
·
24,473 Posts
Yes, wrong forum...but I will add that 'throwing' your car into park is not really recommended. So it seems that the trigger is your sudden stop/shift to park.
If you post on the GV forum on the left, you should put your location in, as well, as US and UK info can differ. On this side of the forum, I would ask if the car stalls if you stop suddenly but DON'T throw it into park?? If so there is an electrical switch on the shift lever that stops the car from being started in anything other than park or neutral, and perhaps your rough treatment has caused a switch/wiring/connection problem....
 
1 - 4 of 4 Posts
Top