Suzuki Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I came here to diagnose a terrible rattling sound my car has been making for awhile now. See this thread and chime in if you have any ideas about it:

http://www.suzuki-forums.com/suzuki-forenza-reno-forum/124906-can-you-identify-sound.html

There's a You Tube video linked to the thread so you can hear the noise.

After reading around the forum I get the impression there are some "quirks" associated with the Suzi line, as well as some workarounds or backyard mechanic tricks/fixes. So I wanted to make this post to see if there were any easy fixes or remedies for 2 lights on my dashboard. One is the speed sensitive steering light and the other is passenger side airbag light. The SSS light comes and goes, and when it rains it typically comes on if it's off. The PSA light is always on. I can feel the heavy steering at low speeds which should be boosted; not a big deal but the light is annoying when it's on and I'd fix it if there was an easy, low/no cost fix. Same for the PSA; we always wear seatbelts, so no big deal, but the light is annoying. And when I say low/no cost I don't mean removing the bulb. I'm looking for an actual fix :) BTW, the car is a 2006 Reno with 210K miles and going strong for the most part. Thanks!
 

·
Registered
Joined
·
3,104 Posts
Hi. Ok so first the ssps. How it works is that at slow speeds you have full power steering and as your speed raises the power steering starts to cut out. This gives the driver a better feel of the road. If the unit isn't working your probably just using full time power steering. Some people on the forum have simply removed the unit when they have trouble with it. As for the air bag, there's a known issue with the system. I believe it's either the sensor in the passenger seat or the wires leading to the sensor. There is no recall at this point that I know of but there is a TSB about the issue.
 

·
Registered
Joined
·
6 Posts
I had the same airbag light issue. It ended up being the passenger seat sensor. I had to replace the lower cushion. I found the whole seat at a junk yard and just swapped out the cushion. There is a known problem with the harness and I was hopping that would have been my issue.
 

·
Registered
Joined
·
3,104 Posts
I don't think it's just a link in the cable. I believe it's either a faulty sensor or harness. I've read the TSB but haven't been able to find any instruction on the recommended fix yet.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
I'll look for the TSB for the airbag thing. Thanks! As far as the SSS, removing what? will remedy the situation? Sensor? Harness? Unhooking it?
 
1 - 6 of 6 Posts
Top