Suzuki Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there everyone
I have a 1995 vitara and the 4th injector is not firing.
Have checked:
- computer
- coil
- timing
- compression test

Anyone have any ideas please?
Thanks so much
 

·
Registered
Joined
·
21 Posts
how u know #4 injetor not firing, u can take a noide light or a 194 bulb and connect to #4 injector and start car the light should flicker on and off at moderte pace if it goes injector has power
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I've had my car at 3 different mechanics and two of them have told me that the 4th injector is not firing. The 1st mechanic didn't know what was wrong with it. Nobody seems to be able to fix it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I am new to this site and don't know if I asked this qu in the right thread??
Any advice would be appreciated.
Thanks
 

·
Registered
Joined
·
1,230 Posts
neither the coil, the timing, or the compression have anything to do with your injector not working. Is the plug not firing or is the injector not injecting fuel into the cylinder? If it's the injector, then you need to determine if the injector is getting a signal. If it's not getting a signal then you most likely have a shorted or grounded wire from the ecU to the injector. If it IS getting a signal but not functioning then you need to replace the injector. I don't know why one of your 3 mechanics wouldn't have told you that.
 
1 - 6 of 6 Posts
Top