Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi - I am knew to this forum and any help would be greatly appreciated. I just recently brought a a Suzuki 1993 Vitara which needs a bit of TLC. I cleaned the interior of the car and ever since then the hazards start flashing and the horn sounds off (i think it may have a factory alarms??). Can anyone point me in the direction to where i disconnect the alarm.
 

·
Super Moderator
Joined
·
24,450 Posts
Ah, you are in the UK, presumably? Normally, with the immobiliser, I believe your check engine light would also be flashing if the immobiliser is the problem, as the immobiliser is connected to the car computer. You have a key fob for the security system??
We have a few UK posters who would be more familiar with this.
 

·
Registered
Joined
·
2,528 Posts
My first Sidekick (sold) had a Suzuki alarm. IIRC there was a switch (black, rocker with a little red light next to it) on the dash that would cause this behaviour. Maybe it was switched during your cleaning.
 

·
Super Moderator
Joined
·
18,413 Posts
there was a switch (black, rocker with a little red light next to it) on the dash that would cause this behaviour

The "Valet" switch. Good point. I hit mine recently by accident while detailing and it drove me nuts for hours. :rolleyes:

 

·
Registered
Joined
·
5,299 Posts
On a 93 the alarm will be an aftermarket unit although it may have been a dealer fitted Suzuki Accessory. You'll have to hunt for the alarm unit its probably up under the dashboard.
 
1 - 5 of 5 Posts
Top