Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey! I've got a real problem with my acceleration. When I give it gas, it sputters for almost 2 seconds before the engine revs up. And I don't mean while I'm driving either. I can just be sitting there, put the gas in, and it sputters before it revs. Can anyone lend me a hint? :(
 

·
Registered
Joined
·
3 Posts
Sputtering 1990 sidekick.

I am just in the process of solving perhaps this same problem but I need a little more info.
Does the car seem to lack power when going up hill and has shifted into an other gear?
Is this sidekick an automatic or manual trany?
Let me know and may be I can be of help.

John.
 

·
Registered
Joined
·
11 Posts
hey fellow canucks go down to loblaws or superstore out west grab a
gallon of methyl hydrate and add it to a full tank. helps absorb any water in
the gas tank. i had a similar problem in my 1 litre metro and this
helped it run much better. also was it really cold out when your engine
hesitated. if the ambient temperature was low and your engine was not at
operating temperature that also could cause it to hesitate.
 

·
Registered
Joined
·
66 Posts
Was it a gradual onset or did it occur fairly rapidly?

Is it at any temperature or just while it is still warming up?

The methyl-hydrate is good to try first, but you can also try fuel injector cleaner as a quick fix. If these don't work it could be time to change your fuel filter, or your choke could be wearing out. Please provide more details on the symptoms so we can help.
 

·
Premium Member
Joined
·
672 Posts
have the same problem with my 94 sidekick 1.6l 16 valve, had the vehicle scoped and showed either bad wire, plug, or cap, did not replace items yet, maybe worth a shot to give it a complete tune-up especially if it hasn't had one yet, can't hurt it even if it does not solve the problem.

hope this helps,

94box.
 
1 - 5 of 5 Posts
Top