Suzuki Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. 2004+ Swift
    Hey all, Trying to diagnose this noise (see video). Does it sound like the starter motor is starting to go? It occasionally tries to start but never quite gets there. Any help with this would be appreciated. Cheers, Ross
  2. Sidekick/Escudo/Vitara/ Geo/X-90 &Tracker(’89-’98)
    Hey everyone! New here so bear with me. 1991 Geo Tracker RWD, 106k miles, 5spd Car has run fine since I bought it and then went to go wash it the other day. No problems but drove it the day after washing, started and drove fine, no issues. stopped at auto zone to get some Wax, and boom. Won’t...
  3. 3G (2006-2014) Vitara & Grand Vitara
    Hi all. I’m new to this , forgive me if this is the wrong place to find answers to questions , if it is could you please guide me through the right channels . I have a Suzuki Grand Vitara , 2007 Trekker , automatic , 2.7l v6 . Blew the engine in it , started throwing a p0341 code after that ...
  4. Suzuki SX4 Forum
    I haven't been able to start my 08 sx4 for a couple months. I'm getting around to fixing it now. The shifter is locked out because it's only registering reverse so it won't let the car start. Any ideas? Do I need something for the shifter or a new TCM? Or is it possibly something else?
  5. 4G (2015+) Vitara and Grand Vitara
    Car doesn't start, dash lights up with the key symbol and exclamation mark flashing and it says Service system start. What is this?
  6. Suzuki Jimny, Sierra & Samurai Forum
    Hi all, For starters I’m a newb to samurais and Suzuki’s in general. I have an 87 samurai and the back left light assembly wasn’t working so I decided to replace both back taillight assembly’s. I noticed the ground wire was cut for some reason. At this point, I decided to continue to swap out...
1-6 of 6 Results
Top