Suzuki Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 28 Results
  1. 3G (2006-2014) Vitara & Grand Vitara
    I have 2007 GV with an automatic transmission. It shifts through all the gears fine but will not move, at least not very well (feels like a completely shot clutch). It also will not go into park and a loud grinding noise happens when you try. My initial thought was something was up with the...
  2. 2G (1999-2005) Vitara & Grand Vitara
    My Vitara had been showing a check engine light that came up as an EGR valve problem a while back. In the past week transmission had been slipping, rough idling, and almost dying while idling. Transmission fluid was really low but whenever I would add some it seemed to disappear, with no signs...
  3. 3G (2006-2014) Vitara & Grand Vitara
    Dear All I have a GV 2008 with a 2.7Liters A27H engine and Automatic transmission with transfer case. Had a problem with radiator and coolant got to the gearbox and i was forced to change it with a used one. After a while of driving with the new gearbox, at low speed and while turning start to...
  4. Suzuki Forenza & Reno Forum
    I have a leak at the oil cooler joint to the lower radiator. It seems it would be a simple as replacing the crush washers, but I'm not having much luck finding any. I tried the copper ones from Harbor Freight and torqued to 50 ft-lbs and it made the issues worse. I read a thread that some one...
  5. 3G (2006-2014) Vitara & Grand Vitara
    I have a 06 Auto 2.7l GV and have not had the transmission serviced since 60k miles and am currently sitting at 160k miles on a rwd. The car shifts and changes gears smoothly and quietly and drives w no stalling or jumping. I just got a better paying job and can finally afford to do much...
  6. Suzuki Swift and Geo Metro Forum
    Hi, hopefully someone might have some insight on here! Recently my Swift has been taking longer to up-shift and I’ve noticed that changing gears in lower speeds (3rd to 2nd for instance) feels a lot less smooth than before. Each gear change requires more revs than usual and is quite noticeable...
  7. Sidekick/Escudo/Vitara/ Geo/X-90 &Tracker(’89-’98)
    So broke a cable, I think its the speedo cable but im probably wrong. Does anyone know where I can find a replacement? Or if i can just replace this part?
  8. Sidekick/Escudo/Vitara/ Geo/X-90 &Tracker(’89-’98)
    Hello everyone, starting on my rebuild and seeing if anyone has recommendations for parts to replace or upgrade. Looks like this one was run hard and oil burned up along with alot of material covering the magnetic in the pan. Any recommendations or advice is appreciated.
  9. Suzuki Jimny, Sierra & Samurai Forum
    I just purchased an 87 Suzuki Samurai. I was trying to drive it to the dmv today to start the registration process but the short 4-wheel drive shifter started grinding and moving all over the place (as if it has jumped out of 2H. Looks and sounded terrible! Can someone please tell me how big...
  10. 4G (2015+) Vitara and Grand Vitara
    Where can I get info on the 636 ddct transmission fitted to my 2016 Vitara. Is there a maintenance manual available?
  11. Other Suzuki Models
    Hi everyone i just bought a suzuki forsa 87 a/t 3d and since my transmission is damage the owner told me that tranny was in good condition so i bought the whole car For 200$ i brought it home i dismantled everything check the transmission fluid was ok but the solenoid wires are cut off is it a...
  12. 2G (1999-2005) Vitara & Grand Vitara
    I was recently given a 2001 Suzuki Grand Vitara 2.7. I was aware that the vehicle needed a water pump & new battery and that it has sit up for the past 6 years. We got the vehicle and tackled the huge job of changing the water pump. It went great, however the power steering pump broke when we...
  13. 2G (1999-2005) Vitara & Grand Vitara
    Hi, I got a a vitara a couple of weeks ago, but before I bought it the last owner adviced me to change the transmission fluis with the filter. But how much oil do I need when I empty de old transmission fluid? I have searched in the internet but I haven't found an answer. Thx for the help
  14. 2G (1999-2005) Vitara & Grand Vitara
    I was directed here for my 03 tracker zr2 auto trans issue. so I’m thinking it’s my shift cable but I’m not sure yet. When i start the car and put it in any gear, I don’t feel it engage. When I give it gas in drive, reverse, 1st, 2nd it all just feels like neutral. Doesn’t go anywhere, RPMs...
  15. 2G (2007+) XL7
    I have an 07 xl7 and replaced cooling fan connectors and fan motors. Was feeling like brakes were locking up because the transmission fluid was getting hot when fan quit. Still feels like it sticks when shifting. Any idea if it's the transmission or any sensor might be causing it?
  16. Suzuki Equator
    Hi All, Curious if anyone here has had their transmission serviced and or swapped. Do Nissan Parts bolt on? Subtle differences? Any info helps, there's not a lot on these vehicles. 2009 Equator RMZ-4 136k
  17. 2G (1999-2005) Vitara & Grand Vitara
    I have the ability to buy a low milage 03 grand vitara for next to nothing It's a 1 owner car. V6 manual transmission. The issue its having is the transmission isn't engaging. It's actually not doing anything.... The owner is an older man who has babied this car all this time. The shifter...
  18. 3G (2006-2014) Vitara & Grand Vitara
    r Hello friends, ladies, gentlemen, comrades, First off I have a 2008 Suzuki Grand Vitara 2.7 V6, 5 Speed Manual, 4 mode 4x4. I am in the US and am looking to rebuild my manual transmission due to a good amount of vibration in the shifter and a unhealthy noise during acceleration through gears...
  19. 4G (2015+) Vitara and Grand Vitara
    I have a 2016 Suzuki escudo(vitara) I had a bad cooling fan then after that and I started to get a heavy idle and a loss of power when reversing up inclines. It doesn't move at all but on flats it does reverse. I have replaced the cooling fan so far, the throttle body so far has been ruled out...
  20. Suzuki Jimny, Sierra & Samurai Forum
    I just bought a 94' jimny. automatic trans. everything was fine until recently. whats happening is when i start my car and i go to place it in drive and i depress the pedal. it doesnt pick up and go. (there is no rmp reading, kinda acts like its in neutral) same thing if i am in reverse. only...
1-20 of 28 Results
Top