Suzuki Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. Sidekick/Escudo/Vitara/ Geo/X-90 &Tracker(’89-’98)
    I got a 1994 Geo Tracker 1.6 8v with 173k miles about a month ago. I have replaced the spark plugs and the car came with a new dist. cap and plug wires. I decided to change out the timing belt and set the valve lash as this was a farm truck owned by an old lady who knew little but to change the...
  2. Sidekick/Escudo/Vitara/ Geo/X-90 &Tracker(’89-’98)
    Hello everyone I’m new to this forum. I’ve read through hundreds of threads but I’m still lost. I have a 1990 Tracker 4x4 5sp 1.6 8v with 38k that is not getting an injection pulse. So far I have replaced the fuel pump and the three capacitors in the ecm(33920-60A32) but still no injection...
  3. 2G (1999-2005) Vitara & Grand Vitara
    Hello, trying to troubleshoot a transmission issue. Here is a summary of what's going on. Car wouldn't start but I knew not battery since voltage was good, radio works and windows roll up and down fine. First intuition told me starter so I banged on that but since not much clearance didn't...
  4. General Forenza & Reno Forum
    I recently changed an alternator, valve cover, and timing cover on my 04 forenza and now it won't start, just sputters a little and teases me, so I put another fuel pump on it thinking it wasn't getting gas, and it's doing the same thing. The only thing I can think of is that I may have broken a...
  5. 3G (2006-2014) Vitara & Grand Vitara
    2006 GV V6 2.7L Alright…If you could please help me out. My GV recently overheated and I replaced the Radiator along with the hose and refilled the coolant liquids and even pulled out the Temperature sensor. Recently my car overheated once again as I was driving home and had to get it towed...
  6. 3G (2006-2014) Vitara & Grand Vitara
    Hello, I have a 4 cylinder 2009 GV. Recently replaced the head gasket and after reassembly the car did not start and lost ecu connection. I checked wiring and it seems to be fine. Also took out the battery before working and checked fuses and relay. Fuel pump is not sending gas to the lines...
  7. Suzuki Jimny, Sierra & Samurai Forum
    1986 Suzuki Samurai Tin Top stock 1.3L running weber carb no modifications I replaced the reverse light switch and now my reverse lights stay on. I tried to undue what I did to start over just in case I did it incorrect and with the switch completely out of the samurai, the reverse lights stay...
1-7 of 7 Results
Top