SMOKING ENGINE - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-13-2004, 11:15 PM   #1 (permalink)
Newbie
 
Join Date: Oct 2004
Posts: 1
Gallery: 0
GORNOR
Default

SMOKING EXHAUST
Bought a Verona at the beginning of the year. Has done abot 15,000 miles but has spent the last 8 weeks in the shop waiting for a new cylinder head to be shipped over.............the original had a design fault and sucked oil into the cylinders thru the pcv valve.
So over 2 months off the road.........reg, insurance, depreciation and lack of use.
Not happy.
Anyone else know anything about this problem...........clearly a design defect in the early releases.
GORNOR is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-14-2004, 05:28 PM   #2 (permalink)
Senior
 
Join Date: Sep 2004
Posts: 197
Gallery: 0
jro4566
Default

I heard that the very early releases had some bugs in them. Thankfully, those bugs were fixed for 05 Veronas. Sorry about your problem!
__________________
2001 Oldsmobile Silhouette
2003 Suzuki XL7
2005 Chrysler 300C

GMInsidenews.com - RCtennis3811, moderator

Cadillac SRX - BREAKTHROUGH
Cadillac STS - another BREAKTHROUGH
jro4566 is offline   Reply With Quote Quick reply to this message
Old 05-05-2005, 03:05 PM   #3 (permalink)
Newbie
 
Join Date: May 2005
Posts: 2
Gallery: 0
bobber
Default

Just last weekend my 04 Verona started to putter. Sort-of breaking down under throttle. Went to the shop, (a bit over and hour away) they told the wife it was the number 1 cylinder. It wasn't smoking or nuthing. I think it is a bad injector. They disconected something and told the wife to drive it home and will call when the part comes in. Got an appointment for saturday am. We'll see then.
bobber is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:17 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.