Auto Trans problem - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-18-2013, 12:36 PM   #1 (permalink)
Newbie
 
Join Date: Apr 2010
Posts: 5
Gallery: 0
bob97321@hotmail.com is on a distinguished road
Default Auto Trans problem

04 Verona
Trans will not shift. At start off it will whine pretty low slowly building involume.

My tach will rise with the speed, untill about 30mp, then it will drop from about 3,000 rpm to 1250rpm, then rise to about 2200 up to 40 mph, then drop to 1500 rpm. Have not noticed how it is at higher mph.

In every other respect it seems to run just fine and still get good mpg.

I took it in to my local mechanic and he shecked the engine light code which indicated it was a bad speed sensor. He says that is the cause of the problem as the trans does nto know when to shift due to the faulty sensor.

Could that be the issue? What are your thoughts?
bob97321@hotmail.com is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-05-2013, 02:02 PM   #2 (permalink)
Newbie
 
Join Date: Apr 2010
Posts: 5
Gallery: 0
bob97321@hotmail.com is on a distinguished road
Default More info

Took the car in for a thorough diagnostics and turns out it is not the trans that is making the whining noise. It is, they say the hub and bearing assembly that is causing the noise.

Ever hear of such a thing?
bob97321@hotmail.com is offline   Reply With Quote Quick reply to this message
Old 02-03-2015, 07:30 PM   #3 (permalink)
Newbie
 
Join Date: Dec 2014
Location: Plains,Pa
Posts: 7
Gallery: 0
Riverpuppy is on a distinguished road
Default

Then why is the trans laboring to go thru the gears?
Riverpuppy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:03 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.