Help with Electrical! Please! - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-31-2013, 11:23 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2013
Posts: 1
Gallery: 0
MichaelFree is on a distinguished road
Default Help with Electrical! Please!

Hey All,

Working on my 04 verona and the story is that ecm fuse ( fuse 15) in the underhood fusebox blows when the engine is cranked. There is a short to ground somewhere in this circuit. Fuel pump relay and fuel pump have been replaced with no change.

Any thoughts at all at what could be causing the issue? Any help would be appreciated, thanks!!!

M
MichaelFree is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-24-2013, 02:29 PM   #2 (permalink)
Newbie
 
Join Date: Feb 2013
Posts: 5
Gallery: 0
stacld87 is on a distinguished road
Default

I had that problem a few years ago and I put the fuse in kind of crooked, like one of the prongs on the fuse went into the fuse holder and the other one not in the hole but beside it. It's kind of hard to explain but I did that and I haven't had that problem since! I think it was burning out and causing the fuse to have a small wobble and when the engine is cranked it would blow, putting it in crooked kept it from wobbling and has worked for 3+ years.
stacld87 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:49 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.