shutter after atf refill - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-14-2011, 11:34 AM   #1 (permalink)
Newbie
 
Join Date: Oct 2011
Posts: 4
Gallery: 0
hurricane99 is on a distinguished road
Default shutter after atf refill

i had to replace my radiator last week on my 04 verona and i accidently stripped one of the transmission bolt threads. a good amount of fluid leaked out and when i tried to drive it to the repair shop the transmission lost its mind flashed the hold light and fell out of gear. had the car towed to the shop were the mechanic told me to either get another radiator or they can install an external cooler. i told him ok and i gave him two gallons of atf and when i picked it up i noticed he only used one. i am still having shutter on startup now but it shifts fine its only at idle what does this be?
hurricane99 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-26-2012, 04:58 PM   #2 (permalink)
f00
Newbie
 
Join Date: Jan 2012
Posts: 5
Gallery: 0
f00 is on a distinguished road
Default

How long did you drive it with the fluid gushing out? It's possible you damaged the tranny if you drove it far enough with a low fluid level.

The mechanic probably didn't use two gallons of tranny fluid because it probably doesn't hold nearly that much.

So, did they install a new radiator or an external cooler? Might want to have it checked out. Just don't go to AAMCO, as they are rip-off artists.
f00 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:21 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.