ABS non-functional - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-02-2011, 04:26 PM   #1 (permalink)
RHA
Newbie
 
Join Date: Mar 2011
Posts: 2
Gallery: 0
RHA is on a distinguished road
Default ABS non-functional

I've got 107K miles on this car and it runs great. However the ABS light has been coming periodically and recently the brake pedal behaves as though I'm driving on ice and generating that fluid sound when making my initial stops for the day. I was told I needed to replace my hub bearings - is this right? Next day - so my research indicates that the sensors are built into the hubs. I'd like to replace them myself being that 3 of the 4 are bad - any tips on getting this done? I figured the first will take a week, the second a day and the third an hour or two. Is there an after market generic part out there?

Last edited by RHA; 03-03-2011 at 10:38 AM. Reason: amended question
RHA is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-05-2011, 01:18 PM   #2 (permalink)
Member
 
Oggy's Avatar
 
Join Date: Jan 2008
Posts: 42
Gallery: 0
Oggy is on a distinguished road
Default

No. You have to buy front and rear wheel hub with ABS sensor. left and right are same, diferent are front and rear. No generic part, becouse sensor is inside the hub.
Mine was replaced in 15-20minutes by mechanic. So better leave it to the profesionals
__________________
Chevrolet Evanda 2.0l 16V 133HP
Oggy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:57 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.