Suzuki Verona overheating - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-18-2010, 02:04 PM   #1 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 5
Gallery: 0
sab0201 is on a distinguished road
Default Suzuki Verona overheating

Please help! Anyone! I have a 2004 suzuki verona. it overheats at low speeds, stop and go traffic, etc. Does not overheat while driving on highway. My dad and I noticed that both of the fans were not blowing. He hooked the motors of the fans directly to the battery and they both came on. Checked the relays to see if they were blown, they were fine. We thought it was the temperate coolant sensor - so we replaced that. One of the fans started blowing yesterday when we did that. Now, today when driving at low speed, overheats and neither fan is blowing again. WHAT IS WRONG WITH THIS CAR?? Please help! Any helps, suggestions is MUCH appreicated!

Sabrina
sab0201 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-18-2010, 02:19 PM   #2 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 2
Gallery: 0
bombz is on a distinguished road
Default

I am not 100%, but you said the relays were fine, as well I would have bypassed them myself and hook them to a manual switch inside the car. Check coolant / radiator fluid as well, and be sure you have enough. Also make sure the radiator is in good shape, perhaps needs replacing.

hope that helps :-s
bombz is offline   Reply With Quote Quick reply to this message
Old 07-18-2010, 02:53 PM   #3 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 5
Gallery: 0
sab0201 is on a distinguished road
Default

Quote:
Originally Posted by bombz View Post
I am not 100%, but you said the relays were fine, as well I would have bypassed them myself and hook them to a manual switch inside the car. Check coolant / radiator fluid as well, and be sure you have enough. Also make sure the radiator is in good shape, perhaps needs replacing.

hope that helps :-s
Thank you so much! We just put new coolant in ita few days ago, but I am worried that I am supposed to have a certain kind. Will those "any makes and models" type antifreeze work?
sab0201 is offline   Reply With Quote Quick reply to this message
 
Old 07-18-2010, 05:21 PM   #4 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 5
Gallery: 0
sab0201 is on a distinguished road
Default

Quote:
Originally Posted by sab0201 View Post
Thank you so much! We just put new coolant in ita few days ago, but I am worried that I am supposed to have a certain kind. Will those "any makes and models" type antifreeze work?
And could it possibly be the thermostat??
sab0201 is offline   Reply With Quote Quick reply to this message
Old 07-20-2010, 09:47 AM   #5 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 5
Gallery: 0
sab0201 is on a distinguished road
Default

Quote:
Originally Posted by sab0201 View Post
And could it possibly be the thermostat??


OK, SO WE HAVE NOW REPLACED THE THERMOSTAT, THE ONE FAN CAME ON AND WE GOT THE CAR IN STOP AND GO TRAFFIC THIS MORNING AND IT OVERHEATED AGAIN, CHECKED THE FANS, AND ONCE AGAIN, NEITHER ONE OF THEM WERE RUNNING. I AM AT MY WITS END WITH THIS CAR. DOES ANYONE HAVE ANY IDEAS OF WHAT TO CHECK NEXT??? I AM IN DESPERATE NEED TO HELP....PLEASE HELP!

THANKS,

SABRINA
sab0201 is offline   Reply With Quote Quick reply to this message
Old 07-21-2010, 07:16 PM   #6 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 5
Gallery: 0
sab0201 is on a distinguished road
Default

Seriously, there is no one that can help me?? PLEASE!?!?!?!!
sab0201 is offline   Reply With Quote Quick reply to this message
Old 07-22-2010, 04:24 AM   #7 (permalink)
Newbie
 
Join Date: Jul 2010
Location: Mars
Posts: 1
Gallery: 0
eric.ran is on a distinguished road
Default

take out the thermostat, it maybe working
eric.ran is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:05 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.