2004 Epica LS Oil Leak, Suspension Noise, Scraping noise around wheels - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-10-2010, 06:42 PM   #1 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 3
Gallery: 0
Teacher2007 is on a distinguished road
Unhappy 2004 Epica LS Oil Leak, Suspension Noise, Scraping noise around wheels

Hi,

Before I take this problematic car back to the garage, which has already cost me more than $1,000 in repairs last year. I would appreciate any advise about 3 current problems. Car has 103,000 KMS

Oil Leak:
I recently noticed oil leaks on the driveway. It seems to be coming from the area near the right front passenger wheel area. I've had problems with this wheel in the past. Warranty repairs to the tie rod a few years ago (they had to do it twice!). I don't know if this might be a factor here. Any idea?

Noise:
When I go over a bump, depending on speed, there is a loud clunking, sqeeking noise in the area of the back right wheel area.

Noise:
Scraping, clicking sounds as I'm driving at low speeds. Sounds like its coming from the wheel area. Stops when I brake or stop. I replaced front brake pads last year, and back pads the year before. Both have lifetime warranty.

Last edited by Teacher2007; 07-10-2010 at 06:49 PM.
Teacher2007 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-15-2010, 09:49 AM   #2 (permalink)
Newbie
 
Join Date: Jun 2010
Posts: 8
Gallery: 0
bigguyadocious is on a distinguished road
Default

Quote:
Originally Posted by Teacher2007 View Post

Noise:
When I go over a bump, depending on speed, there is a loud clunking, sqeeking noise in the area of the back right wheel area.

Noise:
Scraping, clicking sounds as I'm driving at low speeds. Sounds like its coming from the wheel area. Stops when I brake or stop. I replaced front brake pads last year, and back pads the year before. Both have lifetime warranty.
I've had similar issues and have not found the cause. One shop says it could be my struts and strut mounts and another said upper control arm. Might have said lower control arm...have to dig out the paperwork.

I get a squeal when I go over speed bumps. I also have a scraping type sound when I make turns. Sometimes it makes a knocking type sounds like something shifted out of place. I don't have 60K miles yet and my suspension sounds like I have 160k miles.
bigguyadocious is offline   Reply With Quote Quick reply to this message
Old 07-15-2010, 10:08 AM   #3 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 3
Gallery: 0
Teacher2007 is on a distinguished road
Default Problematic Epica 2004

Hi,

What year is your Epica? I would love to trade the car, but can't as I'm still paying on the stupid car loan. I just went through all my repair receipts for last year and spent over $1,700 in repairs!! The thing is only valued at approx. $5,000 right now on the Canadian Black Book. This is completely nuts, and I still have at least 4 problems to fix on the beast.

The coil packs (6 of them) are also starting to go on at a time. I've already replaced two. They are supposed to be guaranteed for at least 160,000 km, and started to go at less than 100,000.

My mechanic said this car drives worse than a 10 year old car, and his Toyota Tercel loaner car, same age, 2004 drives like a new car.

I feel totally trapped with this car, and don't know what to do with it.
Teacher2007 is offline   Reply With Quote Quick reply to this message
 
Old 07-15-2010, 10:11 AM   #4 (permalink)
Newbie
 
Join Date: Jul 2010
Posts: 3
Gallery: 0
Teacher2007 is on a distinguished road
Default

Quote:
Originally Posted by bigguyadocious View Post
I've had similar issues and have not found the cause. One shop says it could be my struts and strut mounts and another said upper control arm. Might have said lower control arm...have to dig out the paperwork.

I get a squeal when I go over speed bumps. I also have a scraping type sound when I make turns. Sometimes it makes a knocking type sounds like something shifted out of place. I don't have 60K miles yet and my suspension sounds like I have 160k miles.


I also was told by a mechanic that the entire control arm needs to be replaced, can't replace a portion because the assembly is sold as a complete unit. Estimated cost of part & labour $500.00 This sound has been going on for years (since 2006) without getting worse.
Teacher2007 is offline   Reply With Quote Quick reply to this message
Old 07-15-2010, 10:38 AM   #5 (permalink)
Newbie
 
Join Date: Jun 2010
Posts: 8
Gallery: 0
bigguyadocious is on a distinguished road
Unhappy

Quote:
Originally Posted by Teacher2007 View Post
Hi,

What year is your Epica? I would love to trade the car, but can't as I'm still paying on the stupid car loan. I just went through all my repair receipts for last year and spent over $1,700 in repairs!! The thing is only valued at approx. $5,000 right now on the Canadian Black Book. This is completely nuts, and I still have at least 4 problems to fix on the beast.

The coil packs (6 of them) are also starting to go on at a time. I've already replaced two. They are supposed to be guaranteed for at least 160,000 km, and started to go at less than 100,000.

My mechanic said this car drives worse than a 10 year old car, and his Toyota Tercel loaner car, same age, 2004 drives like a new car.

I feel totally trapped with this car, and don't know what to do with it.
I actually have a 2004 Verona and I agree, the Beast drives like it's 10 years old or worse. I've been neglecting it hoping to not chase a wild goose repairing multiple parts to find out nothing fixes it. I just paid mine off and fear I could get little to no trade value for it. When I think about what I paid vs what I have, I feel robbed! I might as well had leasted a Honda.
bigguyadocious is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:18 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.