Heater not working..... Stuck on cold.. - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Home Forum Active Topics Photo Gallery Garage Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools
Old 09-19-2009, 09:51 PM  
Newbie
 
Join Date: Aug 2007
Posts: 0
Gallery: 0
32003 is on a distinguished road
Default Heater not working..... Stuck on cold..

Hi all,
last nite my heater packed it in ....Epica 04, 45,000km.. Get no heat at all, no matter where the dial is set to...
I'm hoping it is just a cable as the engine operates at normal temp. .... Any suggestions before the dealership get their hands on my wallet lol.
Michael ....
32003 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-23-2009, 01:19 AM  
Newbie
 
Join Date: Aug 2007
Posts: 0
Gallery: 0
32003 is on a distinguished road
Default Heater cold.. update

Hi all,
just an update to my post Re Heater not working .... Seems that it was a broken cable at a cost of $12 and labor at $260 !!!!! Seems that the radio and glove box had to be removed but ...... Had no option but to get it fixed....... and i'm trading in the car at the end of October .. Oh well, could have been one of those nitemare posts i have been following.
Cheers,
Michael .
32003 is offline   Quick reply to this message
Old 09-30-2009, 07:13 PM  
Expert
 
Join Date: Jan 2008
Posts: 388
Gallery: 0
ewetho is on a distinguished road
Default

And to think when I worked a ZUK we only charged like an hour or less.
ewetho is offline   Quick reply to this message
 
Old 10-01-2009, 12:21 AM  
Newbie
 
Join Date: Aug 2007
Posts: 0
Gallery: 0
32003 is on a distinguished road
Default

Quote:
Originally Posted by ewetho View Post
And to think when I worked a ZUK we only charged like an hour or less.
hi,
Looks like i was charged a shop time of $110/hr ..... as mentioned thank heavens the tranny or similar has not failed :-) ..
But the Epica has been just great . will be sad to see it go but for health reasons (Hip Replacements) i require a vehicle with heigher entry / egress . therefore the RAV will be next.
Take care,
Michael.
32003 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:24 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.