Engine Light - Code P1443 - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-27-2009, 11:43 AM   #1 (permalink)
Newbie
 
Join Date: Jun 2009
Location: Chicago
Posts: 3
Gallery: 0
BertMLou is on a distinguished road
Smile Engine Light - Code P1443

Hi! I'm new to this forum, so I don't know if this question has been addresed yet. I have an 04 Verona and I bought it used. When I first bought the car it ran very smoothly (GREAT). However, after 6 months in the car, I feel like the engine light comes on every other month. I can't sneeze, or turn thw wipers on without it coming on. Each time different codes come up, but surprisingly, the car experiences the SAME problems. I have had all spark plugs replaced, 02 sensors, new battery, etc., the list goes on. Each dealer says that the service I get will fix the problem, but it always comes back with a different code. I have spent too much money trying to fix the same problem, and before I throw my money away again, I wanted to know if anyone on here REALLY knows what's going on with the 04 models of Veronas. The code coming up now is P1443 (something with emission control) You spend an arm and a leg just to get this diagnostic at the dealer. Does anyone know what needs to be done to fix this problem? I am experiencing rough idling, car not starting at the most inconvenient times, and cutting off while switching gears. I'm afraid to go to the dealer with this, because I suspect after I get it fixed, next month my engine light will come on AGAIN with a different code and the SAME problems. Can anyone help? PLEASE!!!! I am unemployed and cannot afford to keep paying for these repairs.
BertMLou is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-27-2009, 05:10 PM   #2 (permalink)
Member
 
evlweevil's Avatar
 
Join Date: May 2009
Location: naugatuck ct
Posts: 86
Gallery: 0
evlweevil is on a distinguished road
Default

These years of veronas have had alot of problems with the ECM going bad. Following the flow chart for this code you either have a bad purge solenoid valve or a bad ECM. By what you are saying that no mater what gets repair you have another problem pop up. The ECM is covered under warrenty for 8/80 (8years/80000miles). Again i stress the fact that these cars have alot of problems with the ECM.
evlweevil is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 06:48 PM   #3 (permalink)
Newbie
 
Join Date: Jun 2009
Posts: 13
Gallery: 0
wolfwood is on a distinguished road
Default

yes i agree with the poster above.. just take it to your dealer and tell them your problem..
__________________
life is an endless book of excitement and surprise...
wolfwood is offline   Reply With Quote Quick reply to this message
 
Old 07-10-2009, 12:15 PM   #4 (permalink)
Newbie
 
Join Date: Jun 2009
Location: Chicago
Posts: 3
Gallery: 0
BertMLou is on a distinguished road
Exclamation When it rains it pours - I NEED A NEW ENGINE AND THE DEALER IS TRIPPING!

(2004 Suzuki Verona)

Hi! Thanks for the replies....now the problem is bigger than I thought. My car cut off on me on the expressway (with my 6yr old in the car). I avoided what would have been a fatal accident. I had my car towed to a reputable repair shop that repairs suzukis and I was told that the #4 plug is smashed on the engine and I needed a new one. It is not in any way in driving condition, so I immediately had it towed to the dealer since I am still covered under the powertrain warranty. I have documented receipts of regular oil changes since the purchase of this vehicle and the dealer tells me that I have to pay $179 just for them to diagnose the problem. Then I was told that they have to "make sure" that the damage is covered under the warranty which is BS because as mentioned...I have been maintaining my car THOROUGHLY as required. I was also told that I will incur ANOTHER pricey fee by Suzuki to tear down the engine to "diagnose" if it is "under warranty". I know that this is a manufacturing problem and that I shouldn't have to come out of my pocket for any of these repairs, but Suzuki is trying to stiff me. I called the corporate office and was told that they can access if I'm covered under the warranty in a week or so. Meanwhile, they are not fixing my problem and I do not have a car. This is unacceptable. Does anyone have any advice on what I should do? I am a single mother and I need a vehicle to get my son to and from school. Not to mention that I cannot afford these "fees" they are trying to shove down my throat. The dealer has had my car for over 24 hours and I have not heard back from them yet.
BertMLou is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:13 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.