Hold Light 2004 Suzuki Verona - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Home Forum Active Topics Photo Gallery Garage Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools
Old 03-12-2009, 04:22 PM  
Newbie
 
Join Date: Mar 2009
Posts: 2
Gallery: 0
jarobinson is on a distinguished road
Cool Hold Light 2004 Suzuki Verona

So i was checking out this site looking for a reason to the hold light and what it does i found that answer now how to get it off? I was driving my car yesterday and the hold light came on out of no where! the button was not pressed down so i decided to press it on and turn it back off thinking it was just a glitch and that would help...well now the button is stuck down and it's driving me nuts when i'm starting off it's like i'm in neutral it's not wanting to go through the gears or anything like that i tried using the manual 1-3 gears but this is not helping what so ever!
jarobinson is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-18-2009, 05:40 AM  
Member
 
Join Date: Jan 2009
Posts: 28
Gallery: 0
Suzukinoob is on a distinguished road
Default

sounds like it might be the trans control module , can't trouble shoot over the inernet though
Suzukinoob is offline   Quick reply to this message
Old 03-19-2009, 01:06 PM  
Newbie
 
Join Date: Mar 2009
Posts: 2
Gallery: 0
jarobinson is on a distinguished road
Default Hold Light

Well i took the hot post off my battery and that seemed to work the light went right off i'm going to keep an eye on it and take it to the dealership just to make sure it's nothing like that going on with it.
jarobinson is offline   Quick reply to this message
 
Old 04-02-2015, 08:30 AM  
Newbie
 
Join Date: Apr 2015
Posts: 1
Gallery: 0
Hawkzwife is on a distinguished road
Default

I am having the same trouble, I have had this car for 14 years and never has the light come on, I did not think the button worked. It was raining and another car splashed a bunch of water on me and the light came on. I can not get it off either...was it from the water, will it dry out. When I take off it is like I am in neutral also. I will have my husband try the battery thing...did that make the car run right again?
Hawkzwife is offline   Quick reply to this message
Old 04-24-2016, 01:26 PM  
Newbie
 
Join Date: Apr 2016
Posts: 1
Gallery: 0
cuffeem is on a distinguished road
Default

Did this ever work for you? Did you figure out the problem because my car is doing the same ever since I went through a huge puddle.
cuffeem is offline   Quick reply to this message
Old 02-11-2017, 05:22 PM  
Member
 
Join Date: Mar 2014
Location: Searcy, AR
Posts: 28
Gallery: 0
jcgss77 is on a distinguished road
Default

This happens to me every time I have a low battery issue. If your starting voltage is not right, there is some kind of issue with the hold light coming on, and the car will not go into 1st gear, but the upper gears work fine(at least in my Verona, a 2006). Make sure your terminals are both corrosion free, and have your battery and alternator tested. I bet this will end that problem.
jcgss77 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:19 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.