Fuel pump delay on cranking 2004 Verona - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-15-2015, 02:10 PM   #1 (permalink)
Newbie
 
Join Date: Jun 2014
Posts: 7
Gallery: 0
cbrian is on a distinguished road
Default Fuel pump delay on cranking 2004 Verona

Hey all,
I've searched and can't find the same issue. When I crank, the fuel pump does not receive power for 3 seconds. Once the 3 second period has passed, it fires up fine. I checked power at the fuse and relay with switch turned to on position, and no power is present. Do you know of an issue that would delay the Ecm to send signal to relay? The time delay is consistent.

Thanks,

Brian
cbrian is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-19-2016, 05:54 PM   #2 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 7,993
Gallery: 0
aquanaut20 is on a distinguished road
Default

The ECU must see spark before it commands the fuel pump...

Having said that there should be a 2sec prime with key on, check the fuel pump relay (may be getting tired), or the fuel pump is dying.

A fuel pressure test is in order...

... Philip
__________________
92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:11 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.