Verona Idle Problems - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-11-2015, 04:42 AM   #1 (permalink)
Newbie
 
Join Date: Jul 2015
Posts: 1
Gallery: 0
Biged is on a distinguished road
Default Verona Idle Problems

Hello all. new to the site and a new owner of a 2004 Verona. I have replaced the dreaded throttle body assy. because the old one had a bad Throttle position sensor. The car now runs very well, but I have noticed a new annoying problem. When you start the car, the idle is normal but as soon as I drop it in gear the idle jumps to 1100 RPM and slowly drops to 650. As I come to a stop sign and the car down shifts, the RPM is still around 1100-1200 RPM, it bucks as it shifts into low gear and the slowly drops to 650. remove my foot from the brake pedal and RPM goes up again. As soon as I put it in park it drops to 650. ??? This is getting annoying and I am afraid I will damage the Transmission. Car has 156K on the clock. Any suggestions on what to try next. Thanks in advance
Biged is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-14-2015, 09:38 PM   #2 (permalink)
Newbie
 
Join Date: May 2015
Posts: 23
Gallery: 0
Duner is on a distinguished road
Default

I think I would start by checking for trouble codes.
Sometimes searching the archives can be helpful.
Duner is offline   Reply With Quote Quick reply to this message
Old 08-18-2015, 09:17 AM   #3 (permalink)
Member
 
Join Date: Jun 2011
Posts: 27
Gallery: 0
epica_pain is on a distinguished road
Default

The worse thing to do with these cars is to replace shit in ot that does not fix it man I bet the throttle costed a lot
epica_pain is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Verona, Chevrolet Epica & Daewoo Magnus Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:19 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.