2007 SX4 Airbag Light behaviour - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-02-2019, 08:16 PM   #1 (permalink)
Newbie
 
Join Date: Jul 2019
Posts: 4
Gallery: 0
07sx4nz is on a distinguished road
Default 2007 SX4 Airbag Light behaviour

Hi all, been doing a little searching and come across these forums, lots of great info here! Wondering if someone may be able to help with the following question.

I'm in New Zealand with a 2007 SX4 (parent's car rather than mine). Recently the airbag light came on out of the blue - it would flash 6 times then stay on when the car was started.

Had the ECU scanned for codes, there were a bunch of historical ones, some regarding low battery voltage so that may even be the culprit, but the one causing the airbag light to stay on was a B1094 - Passenger Side Impact-Sensor Circuit Open.

We visually checked the passenger side impact sensor, wiring was all good, no moisture around the sensor. Cleared the codes to see if they would come back, so far so good, but the airbag light does still flash 6 times when the key is turned on - is this the normal behaviour or is that indicating that there is still an issue there? So far there are no new codes. I never paid enough attention before hand to know if this has always been the case, but am more accustomed to an airbag light just coming on then off the once, not flashing.

One other thought I had was in NZ we are obviously right hand drive rather than left - I assume when we're looking at a passenger side code, this is the left hand side of the car, or is it possibly the right hand side?

Any info would be appreciated! Thanks.
07sx4nz is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-02-2019, 08:42 PM   #2 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,700
Gallery: 0
2013GV is on a distinguished road
Default

light flashing indicates an issue. Should come on solid at key on, go off after starting.

Its quite possible theres a budding fault there, but if theres no new codes i'd keep driving it. Low cranking volts can certainly cause issues, sensors are known to get moisture in them and corrode and wires can and do break inside the insulation. until it throws a code again you will be guessing.

NZ new or a pre loved import?

Which end of the country are you, i know a good ABS specialist in Chch that works wonders with the imports.
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."
2013GV is offline   Reply With Quote Quick reply to this message
Old 07-02-2019, 08:47 PM   #3 (permalink)
Newbie
 
Join Date: Jul 2019
Posts: 4
Gallery: 0
07sx4nz is on a distinguished road
Default

In Tasman area so a wee way away from Chch. OK - thank you. I did think it was a bit odd the light was still flashing on startup.

This is an import - came into NZ in 2014. Has about 160,000 km on it currently. Will get them to keep driving it and see if the light comes on solid again and if so will scan it again.
07sx4nz is offline   Reply With Quote Quick reply to this message
 
Old 07-02-2019, 08:51 PM   #4 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,700
Gallery: 0
2013GV is on a distinguished road
Default

Quote:
Originally Posted by 07sx4nz View Post
In Tasman area so a wee way away from Chch. OK - thank you. I did think it was a bit odd the light was still flashing on startup.

This is an import - came into NZ in 2014. Has about 160,000 km on it currently. Will get them to keep driving it and see if the light comes on solid again and if so will scan it again.
ok, checked, the SX4 import does a "flash" to check lamp then goes off when started, comes on solid with a fault


AIR BAG Light
This light monitors inflators, crash sensors, seat belt pretensioners, the front passenger sensing system, and corresponding electrical circuits.

This light blinks for several seconds when the ignition switch is turned to the “ON” position so you can check if the light is working. The light will come on and stay on if there is a problem in the air bag system or the seat belt pretensioner system.

WARNING:

If the AIR BAG light does not blink when the ignition switch is turned to the “ON” position or stays on or comes on when driving, the air bag system or the seat belt pretensioner system may not work properly. Have both systems inspected by an authorized SUZUKI dealer.


http://www.suzuguide.com/suzuki-244.html
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."

Last edited by 2013GV; 07-02-2019 at 09:51 PM.
2013GV is offline   Reply With Quote Quick reply to this message
Old 07-02-2019, 08:59 PM   #5 (permalink)
Newbie
 
Join Date: Jul 2019
Posts: 4
Gallery: 0
07sx4nz is on a distinguished road
Default

Oh great - so it probably is behaving itself (at this stage anyway).

Does the airbag light on the NZ new ones behave differently than the imports? I was finding conflicting information about it when searching online.
Thanks heaps for the info.
07sx4nz is offline   Reply With Quote Quick reply to this message
Old 07-02-2019, 09:41 PM   #6 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,700
Gallery: 0
2013GV is on a distinguished road
Default

Quote:
Originally Posted by 07sx4nz View Post
Oh great - so it probably is behaving itself (at this stage anyway).

Does the airbag light on the NZ new ones behave differently than the imports? I was finding conflicting information about it when searching online.
Thanks heaps for the info.
nz new stay on solid until started, must remain on for a set time after start then extinguish, I'd have to get the WOf guidelines out to confirm but i think its a min of 5 or 8 seconds.

As yours is an import, the check criteria is "lamp works or flashes and extinguishes after starting"

Lamp remaining on after 10 seconds of starting the engine constitutes a fail
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."
2013GV is offline   Reply With Quote Quick reply to this message
Old 07-02-2019, 09:44 PM   #7 (permalink)
Newbie
 
Join Date: Jul 2019
Posts: 4
Gallery: 0
07sx4nz is on a distinguished road
Default

Great info thanks.
07sx4nz is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:34 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.