2008 SX4 2.0L Upstream Oxygen Sensor - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-16-2019, 08:44 AM   #1 (permalink)
Newbie
 
Join Date: May 2011
Location: Paige Texas
Posts: 16
Gallery: 0
SX4 In Laffayette is on a distinguished road
Default 2008 SX4 2.0L Upstream Oxygen Sensor

Hello all,

At 133k Miles my engine light is on all the time. It shows a 420 code. I want to change the upstream Oxygen sensor. Removing the sensor looks straight forward, but cannot trace the wire to where it plugs in. Has any one replaced the sensor themselves? Do you have a picture or a description on where it plugs in? The youtube videos don't seem to show the plug in view. Thanks,

Howard
SX4 In Laffayette is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-16-2019, 11:22 AM   #2 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,111
Gallery: 0
aquanaut20 is on a distinguished road
Default

With a P0420 code, why are you changing the B1S1?

.... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Old 05-16-2019, 12:40 PM   #3 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

Quote:
Originally Posted by aquanaut20 View Post
With a P0420 code, why are you changing the B1S1? Philip
Right...P420 is associated with the downstream O2 reading....possible catalytic inefficiency...
www.avigex.ca/sx4/P0420.pdf
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250

Last edited by LMP; 05-16-2019 at 12:53 PM.
LMP is offline   Reply With Quote Quick reply to this message
 
Old 05-16-2019, 09:54 PM   #4 (permalink)
Newbie
 
Join Date: May 2011
Location: Paige Texas
Posts: 16
Gallery: 0
SX4 In Laffayette is on a distinguished road
Default

Quote:
Originally Posted by aquanaut20 View Post
With a P0420 code, why are you changing the B1S1?

.... Philip
Hi. THis problem first came up 60k miles ago. Was intermittent. Would be fine for months but then take a long trip and it would show up. Now its all the time. I know the code says Catalitic Efficiency problem. But one of the youtube videos said it was the converter or upstream O2 sensor. I live in a small town and don't trust the mechanics that are nearby, so trying to do it my self. Thanks for your input.
SX4 In Laffayette is offline   Reply With Quote Quick reply to this message
Old 05-16-2019, 10:27 PM   #5 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,715
Gallery: 0
2013GV is on a distinguished road
Default

Quote:
Originally Posted by SX4 In Laffayette View Post
Hi. THis problem first came up 60k miles ago. Was intermittent. Would be fine for months but then take a long trip and it would show up. Now its all the time. I know the code says Catalitic Efficiency problem. But one of the youtube videos said it was the converter or upstream O2 sensor. I live in a small town and don't trust the mechanics that are nearby, so trying to do it my self. Thanks for your input.
have you actually diagnosed it properly or are you just firing the parts cannon based on the code and hoping its the "other" sensor to the one the code says to check first?

Live data graphs are your friend, diagnose the issue first.
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."
2013GV is online now   Reply With Quote Quick reply to this message
Old 05-16-2019, 11:38 PM   #6 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,111
Gallery: 0
aquanaut20 is on a distinguished road
Default

Get a scanner capable of displaying graphs, post a graph of the B1S1 at idle and 2000rpm
then when the CAT is hot, the same scan but on the B1S2...

We cannot help unless we have suitable data...

.... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Access to upstream O2 sensor connections DerrickT 1G (2001-2006) XL-7 2 04-04-2018 03:36 PM
2007 GV 4WD 2.7l V6 Upstream O2 sensor Jarvis_GV 3G (2006-2014) Vitara & Grand Vitara 6 07-22-2017 12:19 AM
1997 16v upstream o2 sensor gogo16v Suzuki Sidekick, Escudo, Vitara, Geo, X-90 & Tracker Forum (1989-1998) 5 10-26-2016 09:21 AM
Upstream O2 Sensor for 2008 SX4 zabicki Suzuki SX4 Forum 5 05-25-2016 01:02 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:10 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.