Car not going 40 mph - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-02-2019, 09:11 AM   #1 (permalink)
Newbie
 
Join Date: Nov 2016
Location: Puerto Rico, USA
Posts: 3
Gallery: 0
Sunday funday is on a distinguished road
Default Car not going 40 mph

Hi All, I have a 2013 sx4 with 123,578 miles on it. A couple of months ago it got the CVT belt adjusted ( due to a recall) . Now 4 months later the car is on limp mode not going over 40 miles and high revs. Could this be an indicator that the CVT is gone?
Sunday funday is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-02-2019, 10:25 AM   #2 (permalink)
Member
 
Join Date: Apr 2008
Location: ON, Canada
Posts: 65
Gallery: 0
uchu is on a distinguished road
Default

Is the engine light on? Do you have an OBDII reader handy? That should give you a head start as to what is causing the issue.
__________________
_____________________________________________
2004 Suzuki XL-7 Limited
uchu is offline   Reply With Quote Quick reply to this message
Old 04-02-2019, 01:10 PM   #3 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,715
Gallery: 0
2013GV is on a distinguished road
Default

CVT belt "adjusted" ??? what did they do?
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."
2013GV is offline   Reply With Quote Quick reply to this message
 
Old 04-02-2019, 02:31 PM   #4 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

Quote:
Originally Posted by Sunday funday View Post
...got the CVT belt adjusted ( due to a recall) ..
Found that
https://www.carcomplaints.com/news/2...problems.shtml
The fault is the electronic control module. It seems the problem you describe is precisely what the recall was intended to avoid....
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250

Last edited by LMP; 04-02-2019 at 02:42 PM.
LMP is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vibration at 40 to 50 MPH PALorenz 3G (2006-2014) Vitara & Grand Vitara 8 09-05-2016 11:36 AM
and it poured gasoline for 40 days and 40 nights zuk4life88 Suzuki Jimny, Sierra & Samurai Forum 7 04-11-2013 02:06 PM
sidekick with hic-ups at 40 to 50 mph Fenman Suzuki Sidekick, Escudo, Vitara, Geo, X-90 & Tracker Forum (1989-1998) 2 01-29-2012 05:08 PM
04 Forenza Auto "jerks" at 40 mph downhill? robblaw General Forenza & Reno Forum 10 08-11-2006 07:21 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:36 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.