Disappearing radiator refridgerant - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-21-2019, 06:12 PM   #1 (permalink)
Newbie
 
Join Date: Nov 2008
Posts: 3
Gallery: 0
robertdgoldberg is on a distinguished road
Default Disappearing radiator refridgerant

I own a 2009 Suzuki SX4. My problem is that I am continuously having to add coolant to my radiator reserve tank (about 1 qt a week). There are no signs of leaks in the coolant system. The motor has been disassembled and reassembled and no problems were found. I have replaced the radiator cap.

Anyone have a suggestion about where else I might look to remedy this problem? Thanks BobGoldberg Asuncion Paraguay
robertdgoldberg is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-21-2019, 06:57 PM   #2 (permalink)
Veteran
 
Join Date: Sep 2014
Location: New Zealand
Posts: 3,715
Gallery: 0
2013GV is on a distinguished road
Default

If you are using that much in a week you have a leak somewhere. Check heater core, cracks in block, head etc. Make sure radiator cap is correct pressure. Is it an auto? check transmission isn't getting contaminated with coolant as well.
__________________
2015 5 dr Grand Vitara 2.4 (daily driver)
1971 V8 HG Holden with 383 stroker 9" torq lok and TH350 trans (the toy)
Mitzi RVR 2.0 (not one of my better buys)
the 2013 3 dr GV is now the off road only toy

"Dogs feel very strongly that they should always go with you in the car, in case the need should arise for them to bark violently at nothing right in your ear."
2013GV is offline   Reply With Quote Quick reply to this message
Old 03-21-2019, 07:08 PM   #3 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,948
Gallery: 0
fordem will become famous soon enough
Default

The heater core is a possibility...
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is offline   Reply With Quote Quick reply to this message
 
Old 03-22-2019, 07:29 AM   #4 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

Quote:
Originally Posted by robertdgoldberg View Post
I own a 2009 Suzuki SX4...
OK at least we know now that you are in Paraguay...best is to write that down in your profile . But we do not know engine type (not sure which are available in Paraguay), mileage,(km), transmission type (AUto have a cooler loop in the radiator, manual do not). Add all of this in your profile or signature with other details...car model (sedan or hatchback...ahh from another of your posts, we know it is a hatchback..but we willnot search all of your posts each time) ), trim, AWD or not....so we do not ask for all of that in future posts.
ALso...why was your engine rebuilt? DId coolant loss begin before or after rebuilt ? Details MAKE a difference between guesses or relevant replies. DO you have a coolant smell when using heater...mmm...in Paraguay, you are probably NOT using the heater....but try it for ANOTHER important detail....and a head gasket failure would impair heater performance(heat would come and go) ....and..and...all other details that can pinpoint to a specific problem, solution...
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250

Last edited by LMP; 03-22-2019 at 07:45 AM.
LMP is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suzuki Disappearing From US Market the flying scotsman Suzuki Sidekick, Escudo, Vitara, Geo, X-90 & Tracker Forum (1989-1998) 9 02-14-2019 10:54 AM
Disappearing coolant SHAWN1024 Suzuki Esteem & Baleno Forum 8 01-08-2017 01:04 PM
Disappearing oil -- Having to add oil often ConnJohnn Suzuki Sidekick, Escudo, Vitara, Geo, X-90 & Tracker Forum (1989-1998) 13 03-28-2013 04:31 PM
Chevrolet Optra5 Radiator thefoggyone General Forenza & Reno Forum 2 01-08-2006 09:32 AM
Engine Oil Leaking Into Radiator sigzag 1G (2001-2006) XL-7 4 12-27-2005 05:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:38 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.