Rattle and oil light. - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Home Forum Active Topics Photo Gallery Garage Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes
  • 1 Post By fordem
 
 
LinkBack Thread Tools
Old 01-19-2019, 08:05 PM  
Newbie
 
Join Date: Oct 2018
Location: Australia
Posts: 17
Gallery: 0
ss2115 is on a distinguished road
Default Rattle and oil light.

2009 SX4 with J20A motor.
Driving in traffic up a long steep hill the engine began to rattle and the oil light flickered a bit and came on.
ASAP pulled off to a flat car park and checked oil - half way between the two marks.
Topped up anyway and rested the car.

On restart, little bit of momentary rattle then disappeared. no oil light.
Abandoned intended trip and headed back home.
Rattle reappeared but engine behaving well otherwise. oil light flickered a bit and came on for short periods and then off again. Rattle though was consistent - no louder or softer and didn't disappear with or without oil light being on.
Stopped and left idling and lifted the bonnet. Suspected overhead gear rattle possibly due to oil starvation. However, rattle seems to be from behind the engine in the area of the alternator/power steering pump. To be sure lifted oil cap on off and rattle sound didn't change at all (ie: if overhead rattle I expected to hear a increase in volume and/or a tone change, but no difference at all).

Decided safe to continue home gently.
Temp okay.
Oil light disappeared up hills, came on downhills and flickered around undecided on the flat.

Stumped.
Are these engines prone sensitive to oil filters like the early Toyota engines used to be? ie: doesn't like an aftermarket oil filter)
Could the oil filter have collapsed internally?
I assume they don't have an external oil pump that may be rattling.
Could the oil pickup in the sump have come loose?

Anyone had a similar experience or know if this is a previously known condition or fault of these engines?

*I'm beginning to suspect the rattle is timing chain due to low oil pressure, although the rattle doesn't change when the oil light is out or on. There's plenty of oil in the sump, so am inclined to change the oil filter and hope for an improvement. If not, I suspect the oil pump may have partially failed or the oil pickup tube is loose. Looked under the car and no damage to sump or anything like that.
ss2115 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-20-2019, 04:09 AM  
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

What is the mileage of the car? Did you buy it new ?
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250
LMP is offline   Quick reply to this message
Old 01-20-2019, 08:34 AM  
Newbie
 
Join Date: Oct 2018
Location: Australia
Posts: 17
Gallery: 0
ss2115 is on a distinguished road
Default

Quote:
Originally Posted by LMP View Post
What is the mileage of the car? Did you buy it new ?
Purchased used at 105,000 kilometres two years ago and now done 136,000 klms.

I've done more research on the J20A motor on google images and thinking the hydraulic tensioner has popped out. Loose chain plus low oil pressure. More likely than a faulty oil filter.
ss2115 is offline   Quick reply to this message
 
Old 01-20-2019, 10:22 AM  
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,949
Gallery: 0
fordem will become famous soon enough
Default

Before you do anything else, how about you connect an oil pressure gauge and see confirm that the pressure is actually low.

Typically, if there is an oil pressure issue, there will be a pattern to it, and you have reported a pattern that suggests that the oil pickup screen may be partially blocked - BUT - with the oil level half way between the marks, the entire pickup should be submerged - so it is still worth the time & trouble to confirm.

Is the J20 engine sensitive to oil filter quality - to some extent yes - personally I will prefer to only use a genuine Suzuki filter, so I keep them on hand, but if I had to, I would not hesitate to use a good quality filter - say Purolator, which is what I use on my other vehicles - I would say as long as the filter has an anti-drain back valve, you can use it.
LMP likes this.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is online now   Quick reply to this message
Old 01-20-2019, 02:58 PM  
Newbie
 
Join Date: Oct 2018
Location: Australia
Posts: 17
Gallery: 0
ss2115 is on a distinguished road
Default

Quote:
Originally Posted by fordem View Post
Before you do anything else, how about you connect an oil pressure gauge and see confirm that the pressure is actually low.

Typically, if there is an oil pressure issue, there will be a pattern to it, and you have reported a pattern that suggests that the oil pickup screen may be partially blocked - BUT - with the oil level half way between the marks, the entire pickup should be submerged - so it is still worth the time & trouble to confirm.

Is the J20 engine sensitive to oil filter quality - to some extent yes - personally I will prefer to only use a genuine Suzuki filter, so I keep them on hand, but if I had to, I would not hesitate to use a good quality filter - say Purolator, which is what I use on my other vehicles - I would say as long as the filter has an anti-drain back valve, you can use it.
Good idea.
Where exactly is the oil sender unit please. Or a connection for oil pressure perhaps.

I did fill the sump back up to the full mark but it made no difference.

I'm sort of convinced now the rattle is timing chain, but not sure why as yet. Oil filter, tensioner, broken guide (but that doesn't explain the oil light).
I did see some reference in researching that the tensioner has some sort of valve behind it (a washer with a hole perhaps) that has been known to break. So maybe the tensioner isn't popped out but gushing excessive oil and not applying pressure perhaps???

Can the timing case be removed with engine in the car? ie: worked on through wheel well?
Does sump have to come off? It looks like the sump can come off in the car - no crossmember in the way. But thats only a cursory look and not up on the jackstands.
ss2115 is offline   Quick reply to this message
Old 01-20-2019, 03:20 PM  
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,949
Gallery: 0
fordem will become famous soon enough
Default

The oil pressure sender is under the exhaust manifold.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is online now   Quick reply to this message
Old 01-20-2019, 03:58 PM  
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

Quote:
Originally Posted by fordem View Post
... as long as the filter has an anti-drain back valve, ....
Good point...but is this a conspicuous specification that one can find on the filter box?...I'll pay attention on my next visit to Canadian TIre and read all the boxes..just for fun..
Myself and others near me , several years ago, have seriously experienced FRAM filters and have at that time noticed a non negligible oil pressure drop compared to other makes. Just to say all filters are not born equal.......
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250
LMP is offline   Quick reply to this message
Old 01-20-2019, 04:49 PM  
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,949
Gallery: 0
fordem will become famous soon enough
Default

Quote:
Originally Posted by LMP View Post
Good point...but is this a conspicuous specification that one can find on the filter box?
Where ever you buy your filters from, they should have an application guide from the manufacturer of whatever brand(s) of filters they carry - you can look up your vehicle and engine and they will list a filter that is based on the vehicle manufacturer's specification - you will find the information on anti-drain back valves there.

I don't know how common it is your neck of the woods, but I have seen many people here who will use a filter based solely on the mounting dimensions, many of them use an L10028 filter for everything they work on - this, by the way will fit your J20, but is not the appropriate filter, as it does not have an anti drain back valve.

Why is this anti drain back valve critical? It prevents the oil in the galleries from draining back through the filter into the pan when the engine is off, it allows oil to reach the overhead cam and hydraulic lifters faster on a cold start, it allows pressure to build faster in the lifters and the hydraulic tensioners in the timing chain system. Why are there filters without it? Because overhead valve engines with pushrods didn't need them.

One last thing - if you know what you're looking for, you can, without reading the box or the guide, by simply eyeballing the filter, determine if it has the valve or not.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage

Last edited by fordem; 01-20-2019 at 05:02 PM.
fordem is online now   Quick reply to this message
Sponsored Links
Advertisement
 
 

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:08 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.