2009 SX4 Starter Replacement - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Home Forum Active Topics Photo Gallery Garage Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools
Old 12-27-2018, 08:51 PM  
Newbie
 
Join Date: Dec 2018
Location: USA
Posts: 4
Gallery: 0
cuelist is on a distinguished road
Question 2009 SX4 Starter Replacement

Hi guys!! I'm new here just got a 2009 SX4!! it has a bad starter how do i remove it???


thanks
cuelist is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-28-2018, 03:53 PM  
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 792
Gallery: 1
LMP is on a distinguished road
Default

...can you give some details that led you to conclude the "starter is bad"...what is mileage of the car ? IS it auto, manual, AWD ? and what trim....pack all of this in your profile or signature..
OK..at least we know you are in the USA, and 2009, so J20A engine, then this might help you
www.avigex.ca/sx4/starter.pdf
however it does not describe what you have to remove first in order to get access...maybe others who had to do it will come and tell...
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250

Last edited by LMP; 12-28-2018 at 04:01 PM.
LMP is offline   Quick reply to this message
Old 01-08-2019, 09:51 PM  
Newbie
 
Join Date: Dec 2018
Location: USA
Posts: 4
Gallery: 0
cuelist is on a distinguished road
Default

Quote:
Originally Posted by LMP View Post
...can you give some details that led you to conclude the "starter is bad"...what is mileage of the car ? IS it auto, manual, AWD ? and what trim....pack all of this in your profile or signature..
OK..at least we know you are in the USA, and 2009, so J20A engine, then this might help you
www.avigex.ca/sx4/starter.pdf
however it does not describe what you have to remove first in order to get access...maybe others who had to do it will come and tell...
Thanks for the reply. I know when a starter is bad I have mechanic experience. Starter will turn after being tapped with metal bar. I wasnt asking for troubleshooting I simply wanted to know if I had to go under the car to do it as I am in winter right now, however I took it out from above, but the connections had to be done from below. Car works perfecetly fine now, it is a SX4 technology package. Its a nice car.

Noteworthy is that suzuki does not make the starters, even though it was the original starter, it still said remanufactured. go figure.
cuelist is offline   Quick reply to this message
 
Old 01-09-2019, 06:40 AM  
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 792
Gallery: 1
LMP is on a distinguished road
Default

Quote:
Originally Posted by cuelist View Post
.. I know when a starter is bad...
Describing your symptoms may help OTHERS (without excellent mechanic experience) figure out what happens to them. Others in the future may take YOUR thread to compare to THEIR problem and see if it is the same, and if the solution that worked for you also would fits theirs . That is the purpose of the forum and why all detals count.
ANd by the way, I searched this and other SX4 forums and found no thread about the way one changed this starter...so your thread might be a first...so be sure to describe the operation and add photos. Others will surely look at it.
ABout the fact you mention the starter is a rebuilt......did you buy the car new ?
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250

Last edited by LMP; 01-09-2019 at 07:23 AM.
LMP is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:49 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.