Hi. Error code P0303 - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-13-2018, 10:03 AM   #1 (permalink)
Newbie
 
Join Date: Aug 2018
Posts: 2
Gallery: 0
sx4 trinidad is on a distinguished road
Unhappy Hi. Error code P0303

Hi All. Thanks for membership.

I have a question, and need some assistance.

Basically, I drive a 2011 SX4 M15A YA11S. Vehicle started losing power and vibrating. Engine Problem light ON.

After Diagnostic scan and resetting, Error code P0303 comes back and does not does not want to go away although I changed all spark plugs, coil packs, and thoroughly service and tested engine at many many mechanics. Is the problem now the Computer and needs changing?

Regards
Shastri
sx4 trinidad is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-13-2018, 03:00 PM   #2 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

P0303: Cylinder 3 Three Misfire
Problem specific to this cylinder only.
spark plug..., coil pack....OK...I would check wiring to coil pack.
Which engine in this one....?..does M15 relates to 1.5 litre engine ?
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250
LMP is offline   Reply With Quote Quick reply to this message
Old 08-13-2018, 08:27 PM   #3 (permalink)
Newbie
 
Join Date: Aug 2018
Posts: 2
Gallery: 0
sx4 trinidad is on a distinguished road
Default Thanks for the reply LMP

engine is a 1.5 L, gas.

I could try and get the wires checked.

I forgot to mention, also on resetting the error code (about several times), it disappears for about 15 to 20 minutes after which it returns. However prior to returning, the vehicle drives perfect, no vibration and accelerates very well. But when the engine light comes back on for no reason, that is where the problem starts back with vibration and lazy acceleration. The rpm gauge also seems to fluctuate about a value when it should be steady.

As for the wires, I could try and take apart and check, but Is there a test other than a visual I can perform? such as a continuity with a multi-meter? and what size wire should I replace it with if I saw a breakage?

Thanks again
Regards
Shastri
sx4 trinidad is offline   Reply With Quote Quick reply to this message
 
Old 08-14-2018, 08:54 AM   #4 (permalink)
Newbie
 
john yayay's Avatar
 
Join Date: Mar 2015
Location: Colorado
Posts: 10
Gallery: 0
john yayay is on a distinguished road
Default

Quote:
Originally Posted by LMP View Post
P0303: Cylinder 3 Three Misfire
Problem specific to this cylinder only.
Just curious, but how does the computer detect a misfire?
O2 sensor could detect poor/no burn. Knock sensor?
john yayay is offline   Reply With Quote Quick reply to this message
Old 08-14-2018, 12:09 PM   #5 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

Quote:
Originally Posted by john yayay View Post
Just curious, but how does the computer detect a misfire?..
an abnormal voltage at the coil pack primary winding is interpreted as a MISFIRE
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250
LMP is offline   Reply With Quote Quick reply to this message
Old 09-18-2018, 10:49 PM   #6 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,102
Gallery: 0
aquanaut20 is on a distinguished road
Default

actually, misfires are triggered by a discrepancy between the CAM and CRANK signals, you will need a scope to see the digital signals..

Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:11 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.