Engine error code - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-30-2018, 04:37 AM   #1 (permalink)
Newbie
 
Join Date: May 2018
Posts: 1
Gallery: 0
zelkisoma is on a distinguished road
Exclamation Engine error code

It has been almost a half year that the engine code lights. First it said that the lambda sensor has to be changed. After it was done, the light was still on and it said that the Catalyst system efficiency below threshold. After that I made also the catalyst system changed, however, the light is still lighting. The computer says the same: "Catalyst system efficiency below threshold", however, it was changed yet. Now I am confused, what should I do? Have you had any similar problem, or any idea for solve this problem?

Thanks in advance.
zelkisoma is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-30-2018, 06:42 AM   #2 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

WOuld be relevant to know where you live, what car model you have, engine, transmision, AWD?, year model...etc.
Fill up your profile and/or signature and replies will start.
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250
LMP is offline   Reply With Quote Quick reply to this message
Old 09-12-2018, 02:25 PM   #3 (permalink)
Newbie
 
Join Date: Mar 2015
Location: Paige, Tx
Posts: 19
Gallery: 0
paigetx is on a distinguished road
Default

Quote:
Originally Posted by zelkisoma View Post
It has been almost a half year that the engine code lights. First it said that the lambda sensor has to be changed. After it was done, the light was still on and it said that the Catalyst system efficiency below threshold. After that I made also the catalyst system changed, however, the light is still lighting. The computer says the same: "Catalyst system efficiency below threshold", however, it was changed yet. Now I am confused, what should I do? Have you had any similar problem, or any idea for solve this problem?

Thanks in advance.
I have had this same problem for 60k miles. the code is 420? Says to replace both oxygen sensors first then the catalytic system last. Car runs great but Cruise Control wont work with light on. On trips I disconnect battery each time I fill up so I have CC for the entire trip. I have the 2.0 with manual and AWD.
paigetx is offline   Reply With Quote Quick reply to this message
 
Old 09-12-2018, 05:41 PM   #4 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,111
Gallery: 0
aquanaut20 is on a distinguished road
Default

Rather than using a parts Cannon, circuit integrity diagnostics should be you route..


Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:37 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.