AUTO light always on. AWD switch failure? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-22-2018, 02:49 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2018
Location: WA State - USA
Posts: 3
Gallery: 0
GP-SX4 is on a distinguished road
Default AUTO light always on. AWD switch failure?

Hi Folks,

The AWD "Auto" light was starting to flash on and off on the dash, intermittently, no matter where I put the switch. Meaning I will be driving and it will flicker on, then be off for awhile. But then it started getting more regular, and now it is constantly on all the time, no matter where I have the button position.

This seems different than the constantly flashing code.

It seems as thought the switch itself is failing. But I took it out, and apart and inspected it, and can't find anything wrong. I now have the switch disconnected completely, which has disabled the AUTO light, and I assume the AWD function.

For what other reason would the AUTO light be constantly on? What should I check next?

If it is still likely the switch, any good ideas on where to get one?

BTW, the vehicle has about 120,250 on it, if that helps.

Thanks for your insights.
GP-SX4 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-22-2018, 04:01 PM   #2 (permalink)
Veteran
 
Darrell.'s Avatar
 
Join Date: Jun 2014
Location: UK
Posts: 4,931
Gallery: 0
Darrell. is on a distinguished road
Default

I have an SX4 workshop manual which should show the switch connectivity. Where are you and can we know the engine and year please.
__________________
2005 Grand Vitara MT 1600se.
Darrell. is offline   Reply With Quote Quick reply to this message
Old 01-22-2018, 04:27 PM   #3 (permalink)
Newbie
 
Join Date: Jan 2018
Location: WA State - USA
Posts: 3
Gallery: 0
GP-SX4 is on a distinguished road
Default

Thank you. I am in WA State, USA. It's a 2008 SX4 hatch. I believe a 2.0 motor.
GP-SX4 is offline   Reply With Quote Quick reply to this message
 
Old 01-22-2018, 05:20 PM   #4 (permalink)
Veteran
 
Darrell.'s Avatar
 
Join Date: Jun 2014
Location: UK
Posts: 4,931
Gallery: 0
Darrell. is on a distinguished road
Default

I'm not familiar with the SX4, but this is what my workshop manual shows for the switch. I'm sure the SX4 owners can probably assist better, but it's a start.

__________________
2005 Grand Vitara MT 1600se.
Darrell. is offline   Reply With Quote Quick reply to this message
Old 01-22-2018, 06:04 PM   #5 (permalink)
Veteran
 
Darrell.'s Avatar
 
Join Date: Jun 2014
Location: UK
Posts: 4,931
Gallery: 0
Darrell. is on a distinguished road
Default

Not sure I understand it really

From the owners manual...
__________________
2005 Grand Vitara MT 1600se.
Darrell. is offline   Reply With Quote Quick reply to this message
Old 01-23-2018, 06:20 AM   #6 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

MOst probably there is something (hardware, components) gone haywire. Confirm the ABS alert light is not showing....cause a failure in any of the wheel sensors would fail the ABS...and the rest. YOu did not mention the model of the car...."tech" models(the higher category..known as JLX in Canada) have ESP and traction control too and those would probably disable if a wheel sensor is dead. So...look for and report EVERythinG.
It could deal strictly with the AWD.....like some wire to the AWD clutch that would be disconnected....
All of that would be confirmed with the KIA scanner...but those alert codes are generally not available with a general purpose scanner you can buy....
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250

Last edited by LMP; 01-23-2018 at 06:26 AM.
LMP is offline   Reply With Quote Quick reply to this message
Old 01-23-2018, 10:52 AM   #7 (permalink)
Newbie
 
Join Date: Jan 2018
Location: WA State - USA
Posts: 3
Gallery: 0
GP-SX4 is on a distinguished road
Default

OK. Thanks everyone for the tips so far. I will do more research and inspections and post what I learn.
GP-SX4 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:21 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.