2009 Suzuki SX4 Crossover Auto AWD P0420 CODE - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-11-2017, 10:56 AM   #1 (permalink)
Newbie
 
Join Date: Nov 2013
Location: Buffalo Grove, IL
Posts: 2
Gallery: 0
punk89 is on a distinguished road
Default 2009 Suzuki SX4 Crossover Auto AWD P0420 CODE

Hi guys,

I have that car which i mentioned in heading. I am getting CEL when it rains and when i go to car wash. After an hour it goes off. A few days ago it snowed and my car's hood was all snow. After that, check engine light came on for two days and then went off. Right now i still got it.

Everything is fine. Idling is good. Performance and fuel efficiency are good like CEL off. I wouldn't tell any difference between CEL is on and off.

Just i hate that when i start the engine it revs above 2000 rpm. And i cant use my cruise control.

Any thoughts???
punk89 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-11-2017, 10:08 PM   #2 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,111
Gallery: 0
aquanaut20 is on a distinguished road
Default

I would be looking for a wiring issue..

... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is online now   Reply With Quote Quick reply to this message
Old 01-11-2018, 12:01 AM   #3 (permalink)
Newbie
 
Join Date: Jan 2017
Location: Estero, FL USA
Posts: 1
Gallery: 0
rmedek is on a distinguished road
Default

Quote:
Originally Posted by punk89 View Post
Hi guys,

I have that car which i mentioned in heading. I am getting CEL when it rains and when i go to car wash. After an hour it goes off. A few days ago it snowed and my car's hood was all snow. After that, check engine light came on for two days and then went off. Right now i still got it.

Everything is fine. Idling is good. Performance and fuel efficiency are good like CEL off. I wouldn't tell any difference between CEL is on and off.

Just i hate that when i start the engine it revs above 2000 rpm. And i cant use my cruise control.

Any thoughts???
Water is probably getting some connector. Don't chase the cruise control issue. Whenever the CEL is on the cruise is disabled. If the CEL light is off, the cruise will work. Go to Auto Zone and get the code read. Look for water intrusion near the coded component. O2 sensor, Mass air flow etc.
rmedek is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:55 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.