Ticking/clicking noise from motor 1500-2500 rpm 2007 SX4 - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-04-2017, 07:44 PM   #1 (permalink)
Newbie
 
Join Date: Sep 2017
Posts: 2
Gallery: 0
greenteagod is on a distinguished road
Default Ticking/clicking noise from motor 1500-2500 rpm 2007 SX4

My girlfriends SX4 has developed a fairly loud ticking sound at a particular RPM range. I'm having trouble identifying what exactly it is. Thought I'd get on here and pick the brains of you individuals to see if anything in particular can be found out.

I've checked out the other posts regarding ticking/tapping/clicking sounds and those seem to be fairly constant at any RPM. With it just presenting itself at a certain range I'm just at a loss for what's going on here.

Thank you for any information you all may have.


greenteagod is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-04-2017, 08:55 PM   #2 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,111
Gallery: 0
aquanaut20 is on a distinguished road
Default

Use stethoscope and track the noise..

... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is online now   Reply With Quote Quick reply to this message
Old 09-09-2017, 04:39 PM   #3 (permalink)
Newbie
 
Join Date: Sep 2017
Posts: 2
Gallery: 0
greenteagod is on a distinguished road
Default

I hear it on the water pump as well as the bracket for the passenger side motor mount and then on the back of the motor as well.

I'm having trouble isolating the source of the sound itself, am hoping someone has heard this particular tick before that can be of help.
greenteagod is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:04 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.