AC Problems - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-24-2017, 11:13 AM   #1 (permalink)
Newbie
 
Join Date: Jun 2017
Posts: 1
Gallery: 0
progmanrob is on a distinguished road
Default AC Problems

I have a 2011 SX4 that I love. I've had issues with the AC for about 6 months. Sometimes it works, sometimes it doesn't. The dealer is now a KIA dealer and they claim the compressor needs replacing.

There is also a noise that has started more recently which I hear when I go above 40mph and then it winds down when you drop the speed. I assumed this was a separate issue but the dealer says it's the same thing.

So my questions for anyone out there are:

1. Is this really the compressor even though it works fine some of the time? I thought maybe just the AC clutch?

2. Is there a noise that can sometimes occur with a problem like this? It does sound like it might be closer to the cabin and does not happen at anything lower than 40mph.

The car is running perfect otherwise and since I can't get a new one, I want this one to last as long as possible!

Any input would be appreciated!
Rob
progmanrob is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-29-2017, 01:13 AM   #2 (permalink)
Newbie
 
Join Date: Jun 2017
Posts: 1
Gallery: 0
Bill Toy is on a distinguished road
Cool S-Cross Air Con Problems

I have an 18 month old S-Cross.
I have had the annoying problems mentioned elsewhere with the satnav and rear sensors and it being prone to stone chip damage - but after a recent service found my aircon not working.
Had it back into the dealer (twice) as they had to get a specialist team in - apparently the S-Cross uses the new gas that can't be re-filled by most dealerships - only to be told the compressor is 'damaged' and so not covered under warranty.
The compressor I'm told is situated low down at the front (a vulnerable place to site it I thought for a 4x4 car) but at looking at it I fail to see how it could be damaged other than by grounding the car (which I haven't)
I'm taking a 2nd opinion but would be interested to hear if anyone else has had similar problems?
Bill Toy is offline   Reply With Quote Quick reply to this message
Old 06-29-2017, 08:34 AM   #3 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,113
Gallery: 0
aquanaut20 is on a distinguished road
Default

Unfortunately, without testing and diagnosing, you are just guessing...

A MM and stethoscope would be first line...

.. Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
 
Old 06-29-2017, 01:37 PM   #4 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 796
Gallery: 1
LMP is on a distinguished road
Default

Quote:
Originally Posted by Bill Toy View Post
... after a recent service found my aircon not working....
Is that directly consequential to the "service".....in which case it is rather a disservice. IF they played in the vincinity of the A/C compressor or sensors, changing oil filter...etc....they may have unplugged something...
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250
LMP is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:34 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.