02 sensor & catalytic converter problem - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-30-2016, 11:12 AM   #1 (permalink)
Newbie
 
Join Date: Nov 2016
Posts: 9
Gallery: 0
pedropil is on a distinguished road
Default 02 sensor & catalytic converter problem

Good morning everyone,

My 2007 SX4 awd sport Check engine light is on and diagnosed with the code P2195 problem or the oxygen sensor bank 1 sensor 1 Upstream.

As per advice my mechanic, i need to change it including the catalytic converter.
called up the mitsubishi here in Winnipeg Canada for that parts and found out that It is expensive.

I would like to ask if you have any suggestions where is the best to buy parts here in Canada, even second hand parts. thank you.
pedropil is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-30-2016, 02:46 PM   #2 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,144
Gallery: 0
aquanaut20 is on a distinguished road
Default

I would think the first need is to properly diagnose the issue rather than just accessing a code..

Have you seen data related to O2 function and what is the fuel trim??

What is the issue with the converter??
Has the function been checked, pressure/temp??

... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is online now   Reply With Quote Quick reply to this message
Old 12-01-2016, 10:16 AM   #3 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 803
Gallery: 1
LMP is on a distinguished road
Default

Quote:
Originally Posted by aquanaut20 View Post
I would think the first need is to properly diagnose the issue rather than just accessing a code....
Yes. Often, a code shows the result of some failure, not the cause.
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250
LMP is offline   Reply With Quote Quick reply to this message
 
Old 12-01-2016, 02:08 PM   #4 (permalink)
Newbie
 
Join Date: Nov 2016
Posts: 9
Gallery: 0
pedropil is on a distinguished road
Default

Thank you guys for the reply.

on DTC it only shows up the "O2 Sensor Signal Biased/Stuck Lean Bank 1 Sensor 1"

But when the mechanic checked it, it came out same symptoms. But he included the catalytic converter is included or need to be change together with the O2 sensor.

But what i'm thinking is, since the O2 sensor has the only problem, that's the only thing im going to repair.

What do you think guys?
Thanks
pedropil is offline   Reply With Quote Quick reply to this message
Old 12-01-2016, 02:43 PM   #5 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,144
Gallery: 0
aquanaut20 is on a distinguished road
Default

need to be change together with the O2 sensor.

This is not correct.. get a new mechanic!

The code relates to the pre CAT O2, there may be several reasons for the Bias code.

It is important to check the live DATA of the B1S1 and fuel trims before embarking on flipping parts.. Especially expensive one like the CAT, Proper diagnosis is imperative..

... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:52 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.