Heated oxygen sensor #2 wiring SX4 2012 1.6 16v - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-19-2016, 02:27 PM   #1 (permalink)
Newbie
 
Join Date: Nov 2016
Posts: 2
Gallery: 0
Ravas2016 is on a distinguished road
Default Heated oxygen sensor #2 wiring SX4 2012 1.6 16v

So my car was in a crash almost 2 years ago... And ever since then check engine light was on. Scanned it yesterday and the code was P0036... Car is 100% perfect fine except that engine light. I downloaded Suzuki service manuals and couldn't find how to connect wires from sensor to the ECM. If anybody knows how to connect this, please tell me... Searched everything and no luck.
BTW sensor is from Bosch(it has 2 white,black and a grey wire).
Ravas2016 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-19-2016, 04:14 PM   #2 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,146
Gallery: 0
aquanaut20 is on a distinguished road
Default

The 2 white wires are for the heater, black for sensor ground and the grey for the signal..

Why did you get a universal instead of a P/P.. Did you test the circuit??

http://www.autocodes.com/p0036_suzuki.html

... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k

Last edited by aquanaut20; 11-19-2016 at 04:16 PM.
aquanaut20 is offline   Reply With Quote Quick reply to this message
Old 11-23-2016, 01:04 PM   #3 (permalink)
Newbie
 
Join Date: Nov 2016
Posts: 2
Gallery: 0
Ravas2016 is on a distinguished road
Default

I know the wires from the O2 sensor, but the problem is that I dont know how to connect wires from ECM to the O2 sensor. Car came with that sensor when we bought it, it had one previous owner. Didnt check the voltage though.
Ravas2016 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:46 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.