2012 Idle RPM - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-29-2016, 07:03 AM   #1 (permalink)
Newbie
 
Gene13's Avatar
 
Join Date: Feb 2013
Location: Denver
Posts: 20
Gallery: 0
Gene13 is on a distinguished road
Default 2012 Idle RPM

I recently retired my 2007 SX4 230 K Miles on it. Still running like a champ. I now have 2012 SX4 when I take off from a stop it will stutter if I let my rpm get to low. My 2007 would do that when I got 80k miles on the spark plugs. I changed the spark plugs on this 2012 but that did not completely fix the issue. What is the idle rpm on the 2012. It is setting at 500 rpm that seems a bit low.

Gene
Gene13 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-29-2016, 11:59 AM   #2 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,146
Gallery: 0
aquanaut20 is on a distinguished road
Default

There are a multitude of causes for your low idle, from

dirty MAF,
Dirty IAC,
dirty throttle body,
bad IAC,
low fuel pressure,
restricted intake, and more...

It needs diagnosis, do not guess and throw parts

.... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Old 06-29-2016, 01:24 PM   #3 (permalink)
Newbie
 
Gene13's Avatar
 
Join Date: Feb 2013
Location: Denver
Posts: 20
Gallery: 0
Gene13 is on a distinguished road
Default SX4 2012 Idle

What should it be idling at?
Gene13 is offline   Reply With Quote Quick reply to this message
 
Old 06-29-2016, 02:08 PM   #4 (permalink)
Veteran
 
aquanaut20's Avatar
 
Join Date: Oct 2007
Location: FraserValley, BC, Canada
Posts: 8,146
Gallery: 0
aquanaut20 is on a distinguished road
Default

The idle is a symptom not the cause, find the defect and the idle will fix itself...

... Philip
__________________
.... Philip

92 Ford Explorer, 450k
97 Ford Explorer, 400k
99 Tracker, 4dr, 4x4, 2L DOHC, auto 265k
aquanaut20 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:46 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.