Oil on Spark Plugs - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-01-2016, 08:44 PM   #1 (permalink)
MMM
Newbie
 
Join Date: Dec 2015
Posts: 2
Gallery: 0
MMM is on a distinguished road
Default Oil on Spark Plugs

Hi,

I've had an intermittent P0420 for some time, and have changed both O2 sensors with OEM. Light continues.

Just changed the spark plugs, and they are a bit oily. I'll attach a photo here.

Googling around makes me think that the cat is responding to oil getting into the system. Which would likely be rings or valves... not good! Will be very grateful for any suggestions.

Thanks!

2009 SX4, 94k miles
Attached Thumbnails
Oil on Spark Plugs-img_6005.jpg  
MMM is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-02-2016, 02:03 PM   #2 (permalink)
Expert
 
Join Date: Jul 2008
Location: New Zealand
Posts: 387
Gallery: 0
PaulD is on a distinguished road
Default

Are they the original plugs or the replacements? My 1st impression was the gaps look wide.
PaulD is offline   Reply With Quote Quick reply to this message
Old 03-02-2016, 02:43 PM   #3 (permalink)
MMM
Newbie
 
Join Date: Dec 2015
Posts: 2
Gallery: 0
MMM is on a distinguished road
Default

Quote:
Originally Posted by PaulD View Post
Are they the original plugs or the replacements? My 1st impression was the gaps look wide.
Thanks, PaulD. Not sure, bought the car second-hand four months ago...

Just checked the gaps, and they are all in-spec: between .040 and .044", 1.0 and 1.1 mm.
MMM is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:30 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.