please help!! need new washer fluid pump?? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-13-2016, 08:59 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2016
Posts: 3
Gallery: 0
Daniel4 is on a distinguished road
Default please help!! need new washer fluid pump??

Im having an issue on my 2008 sx4... washer jets worked fine, then didn't, found break in hose, fixed it, still no flow. getting solid pump noise for rear washer fluid but no noise for front jets. Are there seperate pumps for the front and rear washer jets? anyone else had this problem? could there be anything other than the pump causing this? couldn't find find a fuse labeled washer fluid pump or anything similar...
Daniel4 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-14-2016, 10:59 AM   #2 (permalink)
LMP
Veteran
 
LMP's Avatar
 
Join Date: Oct 2011
Location: Chicoutimi, Saguenay,Qc,Canada
Posts: 804
Gallery: 1
LMP is on a distinguished road
Default

WHere do you live? Can cold be a factor?
Of course, 2 pumps, as said in adjacent thread you looked at first. WILl look at shop manual and post whatever is availalble
__________________
2011 sx4 JX 2.0 AWD CVT at 35500km(may2019)- 1928 Model 629 Graham-Paige - 1993 Pontiac Transport 3.8 - 2015 Kia Sorrento 2.4 AWD - 1994 Kawasaki Ninja EX250
LMP is offline   Reply With Quote Quick reply to this message
Old 01-15-2016, 07:52 PM   #3 (permalink)
Member
 
2slow4now's Avatar
 
Join Date: Nov 2014
Location: southern indiana
Posts: 33
Gallery: 0
2slow4now is on a distinguished road
Default

I found a small check valve in my 93 sidekick washer hose. The only thing I can figure is to pump washer fluid that far they put a check valve in so it stays full and doesn't drain back to the tank.
No idea if yours has a check valve inline but it may be something to look for.
2slow4now is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:56 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.