SX4 squealing noise when turning left? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-03-2007, 03:25 PM   #1 (permalink)
 
Join Date: Apr 2007
Posts: 2
Gallery: 0
mclellan is on a distinguished road
Default SX4 squealing noise when turning left?

I have the SX4 (not sport) automatic. A couple days ago I noticed that when I make left turns there is a squealing sound. I thought maybe it was the tires, but no matter the speed of the turn, it was still there. Not so much when I turn right and after a bit of trial and error - it does NOT squeal on left turns when the fan and/or AC is OFF. I'm going to get it checked out, but wanted to see if anyone here ever had this happen.

TIA.
mclellan is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-06-2007, 05:27 PM   #2 (permalink)
Member
 
Join Date: Mar 2007
Location: central VA
Posts: 86
Gallery: 0
bsedwebt is on a distinguished road
Default

thank goodness for warranties - take it to your dealer for the free fix. I will bet belt tension is the culprit since it only does it when the a/c compressor is running. You may have a restriction or contamination in your power steering system as well that is not enough to show itself until the extra strain due to the a/c compressor kicks in and/or the alternator is working a bit harder.
bsedwebt is offline   Reply With Quote Quick reply to this message
Old 04-07-2007, 09:37 AM   #3 (permalink)
 
Join Date: Apr 2007
Posts: 2
Gallery: 0
mclellan is on a distinguished road
Default

Yes, have to love the warranty. I took it in and they "found left lower control arm noisy. Readjusted arm and tightened all bolts on front suspension"

It doesn't make the sound any more so that must have been the issue. It was lucky that I also noticed the passenger side floor was wet the morning I took the car in as the AC drain was dripping IN to the car instead of out of the car. Two problems fixed.
mclellan is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Other Suzuki Models > Suzuki SX4 Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:43 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.